Advance Steel

Tutorial
Table of contents

About this tutorial ........................................................................................................................................... 7

How to use this guide ........................................................................................................................................ 9

Lesson 1: Creating a building grid .................................................................................................................. 10
   Step 1: Creating an axis group in the X direction ....................................................................................... 10
   Step 2: Creating an axis group in the Y direction ....................................................................................... 12

Lesson 2: Creating columns .......................................................................................................................... 15
   Step 1: Creating a column with an I section ............................................................................................... 15
   Step 2: Copying a column ............................................................................................................................ 17

Lesson 3: Creating beams .............................................................................................................................. 20
   Step 1: Creating beams with I sections ....................................................................................................... 21
   Step 2: Creating beams with I sections between columns flange middle ................................................... 23
   Step 3: Modify properties for several beams ............................................................................................... 24
   Step 4: Splitting beams at a given point ...................................................................................................... 26
   Step 5: Splitting beams at a given distance ................................................................................................. 28
   Step 6: Copying beams at a distance below ................................................................................................. 29
   Step 7: Creating a curved beam .................................................................................................................. 31
   Step 8: Creating purlins ............................................................................................................................... 35

Lesson 4: Creating structural elements ......................................................................................................... 39
   Step 1: Creating cross bracings .................................................................................................................... 39
   Step 2: Creating a joist .................................................................................................................................. 44
   Step 3: Moving the joist ............................................................................................................................... 47
   Step 4: Other adjustments ........................................................................................................................... 48

Lesson 5: Defining model views ................................................................................................................... 50
   Defining a view with 1 point in the UCS ........................................................................................................ 51
   Defining a view with 2 points in UCS and front and rear depth .................................................................. 54
   Defining a view at a grid line ........................................................................................................................ 57

Lesson 6: Working with intelligent connections ............................................................................................ 60
   Step 1: Creating a base plate joint .............................................................................................................. 61
   Step 2: Creating a group of base plate connections .................................................................................... 62
   Step 3: Adding a connection to an existing group ....................................................................................... 64
   Step 4: Removing a joint from a joint group ............................................................................................... 65
   Step 5: Modifying the properties of a simple joint ...................................................................................... 65
   Step 6: Modifying joint properties within a group ...................................................................................... 68
   Step 7: Creating independent joints of the same type ............................................................................ 74
Lesson 7: Creating intelligent connections

Step 1: Creating a moment end plate
Step 2: Creating double side end plates with safety bolts
Step 3: Creating gable wall end plates
Step 4: Creating front plate splices
Step 5: Creating clip angle joints
Step 6: Creating a clip angle skewed joint
Step 7: Creating copes
Step 8: Creating purlin connections
Step 9: Creating a flat bracing with tension bolt for a base plate
Step 10: Creating a flat bracing with tension bolt for a beam
Step 11: Creating middle gusset plates
Step 12: Creating a tube connection with sandwich plates for the base plate
Step 13: Creating a tube connection with sandwich plates for a beam as an additional object
Step 14: Creating a tube connection middle with sandwich plates

Lesson 8: Collision check

Step 1: Checking for collisions
Step 2: Displaying a collision
Step 3: Repairing the collisions

Lesson 9: Displaying connected objects

Step 1: Displaying objects connected in shop
Step 2: Displaying connected objects
Step 3: Displaying connection means

Lesson 10: Creating cameras

Step 1: Inserting a camera according to the UCS
Step 2: Moving the camera
Step 3: Changing the camera color

Lesson 11: Numbering

Step 1: Setting prefixes
Step 2: Numbering
Step 3: Displaying the results

Lesson 12: Drawings

Step 1: Automatic detailing of all the single parts in the model
Step 2: Modifying the properties of a detail
Step 3: Automatic detailing of all the main parts in the model
Step 4: Inserting a structured list in a drawing
Lesson 13: Generating details using cameras ...........................................................................................155
  Step 1: Inserting a level symbol in the model...............................................................................................155
  Step 2: Creating details using cameras .......................................................................................................157
  Step 3: Inserting a level symbol in the drawing............................................................................................159

Lesson 14: Exploding details ..........................................................................................................................160
  Step 1: Adding to explode details.................................................................................................................160

Lesson 15: Creating external lists ...................................................................................................................163
  Step 1: Creating a model extract..................................................................................................................163
  Step 2: Creating a list ...................................................................................................................................164
  Step 3: Exporting a list ..................................................................................................................................165
GRAITEC provides a multimedia tutorial to help you learn how to use various Advance tools.

The tutorial contains step-by-step instructions for creating Advance elements, connections, drawings, lists and understanding Advance functions.

During the first 7 lessons, you will learn how to use the most common Advance construction elements (i.e., beams, plates, connection elements, structural elements) and joints and you will create a steel structure.

In the next lesson, the model is checked for errors using Advance tools for checking collisions in the model.

The tools for displaying connected objects are described in Lesson 9.

In the following lessons, the model is numbered and then used to create drawings.
How to use this guide

Simply go through the tutorial and create the model from scratch following the procedures described in each lesson!

The first page of each lesson presents the lesson content (what you will learn). If some additional concepts or techniques are useful, these are also presented.

Additionally, recommended practices and tips and tricks are included during the lesson.

This tutorial does not explain all Advance features and commands. For more details, see the online help.
Lesson 1: Creating a building grid

Placing a building grid is the first step of 3D modeling in Advance. In this lesson, you will create a building grid that is used in the following lessons of this tutorial. Grids facilitate placing of the construction elements and for orientation in the 3D view.

You will learn how to:

- Create an axis group by distances
- Define the axis labels

The following examples describe how to create a building grid with axes in the X and Y directions, with the distances given in Figure 1.

![Figure 1: Building grid – Top view](image)

**Step 1: Creating an axis group in the X direction**

In this step, create an axis group in the X direction and label it with capital letters.

1. On the Home tab, Objects panel, click ![axis group icon](image) to create an axis group at a given distance.

2. On the command line, enter the starting point of the first axis of the group 0,0,0 and press Enter.
3. Move the mouse pointer in the Y direction (the Ortho setting causes an exact orientation entry) and enter 19000 to define the end point of the grid line.

![Image of defining the end point of the grid line]

Figure 2: Defining the end point of the grid line

4. Select a point in the X direction on the screen to define the direction of the axis group.

![Image of defining the direction of the axis group]

Figure 3: Defining the direction of the axis group

5. Define the distances between grid lines by entering each distance between axis: 1500, 1000, 3500, 2500, 1000, 1500.

The command line displays a total value of 11000.

6. Press Enter twice to confirm the axis group creation.

The axis group in the X direction is created and the properties dialog box appears.
7. On the **Total** tab, from the **Label Type** drop-down list, select **Capital Letters**.

![Figure 4: Axis group in the X direction – labeling options](Image)

**Step 2: Creating an axis group in the Y direction**

Next, create an axis group in the Y direction and label it with numbers.

1. On the **Home** tab, **Objects** panel, click ![Image](Image).

2. Define the start point of the first axis of the group: click on the **G** axis corresponding end point as in the ![Figure 5: Defining the starting point of the axis group](Image)
3. Define the end point of the grid line by dragging the mouse pointer (with the Ortho mode on, F8) to the A axis corresponding end point as in the Figure 6:

Figure 6: Defining the end point of the axis group

4. Select a point in the Y direction on the screen to define the direction of the axis group.

Figure 7: Defining the direction of the axis group

5. Define the distances between grid lines by entering each distance between axes: 1000, 3000, 6000, 4000, 5000.

The command line displays a total value of 19000.

6. Press Enter twice to confirm the axis group creation.

The axis group in the Y direction is created and the properties dialog box appears.
7. On the **Total** tab, from the **Label Type** drop-down list, select **Numbers**.

![Figure 8: Properties dialog box](image1.png)

![Figure 9: Final Grid Axis](image2.png)
Lesson 2: Creating columns

In this lesson, you will create columns using the grid axis from Lesson 1 – “Creating a building grid”. You will learn how to:

- Create a column with an I Section
- Create a column with a Rectangular Hollow Section
- Modify column properties
- Copy a column

Concept

Columns of a default length are created in the Advance 3D model vertically, regardless of the current user coordinate system (UCS), by entering one base point.

The column length can be changed by using the grips. The default length of the column is defined in the GRAITEC Advance Manager.

Step 1: Creating a column with an I section

In this step, create a column with an I section at the C1 axis intersection and modify its properties.

1. On the Home tab, Objects panel, click .

3. Select the base point of the column at the C1 axis intersection.

Figure 10: Creating the first column with I section

The properties dialog box appears.
Modifying column properties

Once the column is created, in this example, change the section, the material and rotate the column. In the properties dialog box, define the following settings:

- On the **Section & Material** tab:
  - Use the buttons and make the following settings for the column section:

  ![Section & Material tab](image1)

  Figure 11: “Beam” dialog box – **Section & Material** tab

- On the **Positioning** tab:
  - Select the 90.00° angle.

  ![Positioning tab](image2)

  Figure 12: Column with I section

**Note:** Note that on the **Naming** tab, the model role is set by default to **Column**.

![Naming tab](image3)

Figure 13: **Naming** tab – the model role
Using a similar process, create a column with a rectangular hollow section (RHS140X8) at the G6 axis intersection.

In the properties dialog box, on the **Section & Material** tab, use the buttons and make the following settings for the column section:

- Select the section class: **RHS square cold**.
- Select the section size: **RHS140x8**.

![Figure 14: Creating first column with Rectangular hollow section](image)

**Step 2: Copying a column**

In this step, the column situated at the C1 axis intersection is copied to the A4, A5, B2, B3, B4, E1, F2, F3, G3, G4, and G5 axis intersections.

To create the columns at the axis intersection, activate the **Grid intersection** OSNAP mode.

![Figure 15: Drafting settings – Steel Osnap tab](image)

1. Select the column.
2. On the **Tools** tool palette, click .
3. Select the base point of the copying procedure: the base point of the C1 column.

*Use the **Real-Time Sphere** tool to rotate the drawing in 3D and get a suitable view.*

4. Define the end points for the newly created columns: axis intersections E1, B2, F2, B3, F3, G3, A4, B4, G4, A5, G5.

Figure 16: The 12 columns with I sections

5. Press Esc to finish.

**Modifying column positions**

The position of columns can be changed using Advance Steel properties:

1. Select the B2 and F2 columns.

2. Right click and select **Advance Properties** from the context menu.

3. In the properties dialog box, on the **Positioning** tab, select the $-90.00^\circ$ angle.

The column position is modified.

Figure 17: Changing orientation of the two columns
Using the same process from step 2, copy the column with Rectangular hollow section to the D6, C6, and A6 axis intersections.

Figure 18: 12 columns with I sections and 4 with rectangular hollow sections
Lesson 3: Creating beams

In this lesson, you will create beams using the columns created in Lesson 2. You will learn how to:

- Create beams with I Sections
- Split beams
- Copy beams
- Select objects according to different criteria
- Create a curved beam
- Create a channel section beam

Concept

Beams are created in the Advance 3D model relative to the current user coordinate system (UCS) by entering one start point and one end point. The current user coordinate system (UCS) determines the position of the sections' main axes: the web of a beam runs in the Y direction of the UCS (i.e., the 'top' of the section is in the Z direction).

Before starting

Make sure that the Node OSNAP mode is active. It is useful for start and end point selection.

Figure 19: Properties dialog box – Activating Node OSNAP mode
Step 1: Creating beams with I sections
In this step, create a beam with an I section between the C1 and E1 columns and adjust its position.

Make sure the current UCS is in a suitable position (see Figure 20), otherwise use the three buttons on the UCS tool palette to place it correctly.

1. On the Home tab, from the Objects panel, select the I section.

2. Use the upper system line end point of the C1 column as the start point.

Figure 20: Selecting the start point of the beam: the upper system line end point of the C1 column
3. Use the upper system line end point of the E1 column as the end point. The properties dialog box appears.

**Modifying beam properties**

In the beam properties dialog box, define the following settings:

- **On the Section & Material tab:**
  - Select the section class: IPN.
  - Select the section size: IPN280.

![Figure 21: Section & Material tab – Selecting the section type](image)

**Note:** All the following I section beams will have the same section class and section size.

- **On the Positioning tab:**
  - Define the offset in Z direction: -140.

![Figure 22: Offset tab – Setting the offset](image)

![Figure 23: The beam with I section](image)
Using the same process, draw other beams with the same sections between the F2-F3, F3-G3, G3-G6, G6-A6, A6-A4, A4-B4 and B4-B2 columns. Next, draw another beam between the B4 and G4 columns.

Figure 24: Creating the beams

**Step 2: Creating beams with I sections between columns flange middle**

Next, create 2 beams with I sections between the E1–F2, C1-B2 columns flange middle and modify their section, position and model role.

1. On the **Home** tab, from the **Objects** panel, select the I section.

2. Use the lower flange middle point of the E1 column as the start point.

3. Using the same process, use the upper flange middle point of the F2 column as the end point (see Figure 25).

Figure 25: The beam with an I section between columns flange middle: E1-F2
Using the same process, draw another beam with the same I section between the B2 and C1 columns flange middle.

![Figure 26: The final result: all created beams](image)

**Step 3: Modify properties for several beams**

In this step, adjust the position of all beams of the model, in the same time. To do this, it is necessary to put the objects having the same properties in a selection set.

As all beams have the same section, it is possible to identify them defining a search criteria based on the section type and size in the “Search filter”. All objects matching the search criteria will be marked in red.

Additionally, define the model role. You can assign a role to several objects at once as long as they are of the same type (e.g. beam, plate, etc.).

**Best practice:** Always use model roles, as this defines the prefix in numbering and also has influence with the drawing output. The drawing styles link to the Model roles to set the style within the process.

**Marking objects**

Mark all the profiles with an **IPN280** section.

1. On the **Selection** tool palette, click.
2. In the “Search and mark objects” dialog box, define the following settings:
   - On the **Objects** tab, select the type of objects to select: **Steel beam**.

![Figure 27: Search filter dialog box – Objects tab](image)
• On the **Beams** tab:
  − Select the section class: **IPN**.
  − Select the section size: **IPN280**.

![Figure 28: Search filter dialog box – Beams tab](image)

**Note:** If the section class to be selected is not in the list, unwind **All** in the drop-down list.

3. Click **OK**. The beams are marked in red.

![Figure 29: The profiles with an IPN280 section](image)

4. On the **Selection** tool palette, click to select the marked objects.

**Modifying beam properties**

1. Right click and select **Advance Properties** from the context menu.
2. In the properties dialog box, define the following settings:
   • On the **Positioning** tab, select the orientation of the beam.

![Figure 30: Positioning tab – Modifying the orientation](image)
• On the **Naming** tab:
  – Set the model role to **Rafter**.

![Figure 31: Naming tab – Defining the model role](image)

3. On the **Selection** tool palette, click ✗ to cancel the markings.

**Step 4: Splitting beams at a given point**

Next, split the **G3-G6**, **A4-A6**, **B4-B2** beams at the upper system line end points of the **G4**, **G5**, **A5**, and **B3** columns.

![Figure 32: The beams to split](image)

1. On the **Beam features** tool palette, click 🎨.
2. Select the **G3-G6** beam and press Enter.

![Figure 33: Selecting the G3-G6 beam](image)
3. Select the splitting points: the upper system line end points of the G4 and G5 columns and press **Enter**.

![Figure 34: The splitting points for the G3 – G6 beam](image)

The beam is split.

![Figure 35: Splitting a beam](image)

Using the same process, split the A4-A6, B4-B2 beams at the upper system line end points of the A5 and B3 columns, respectively.

**Note:** Use the **Repeat** command to repeat the last executed command – in this case, **Split beams** command.

![Figure 36: Splitting points for the A4-A6 and B2-B4 beams](image)
Step 5: Splitting beams at a given distance
First create two auxiliary lines along the A6-G6 beam using the line tool. The beam will be split at the end points of the created lines.

Drawing the auxiliary lines
1. On the Utilities tab, Draw panel, click .

2. Use the upper system line end point of the C6 column as the start point.
3. Move the mouse pointer in the X direction (the setting Ortho causes an exact orientation entry) and enter 700 to define the line end point.

Following the same steps, create another line with the D6 system line end point as the start point, oriented in the –X direction, with a value of 400 to define the line end point.

⚠️ Make sure the Dynamic Input is off.

4. Press ESC.
**Splitting the beam**

1. On the **Beam features** tool palette, click 🔄.
2. Select the **A6-G6** beam and press **Enter**.
3. Select the first splitting point: the end point of the line from the **C6** column.
4. Select the second splitting point: the end point of the line from the **D6** column.
5. Press **Enter**.

The beam is split.

---

**Step 6: Copying beams at a distance below**

In this step, copy the **G5-G6**, **G3-G4**, **G3-F3**, **A4-B4**, **A4-A5**, and **A5-A6** beams **2500** distance below.

1. Select the following beams: **G5-G6**, **G3-G4**, **G3-F3**, **A4-B4**, **A4-A5**, **A5-A6**.

---

2. On the **Tools** tool palette, click 🔄 to copy the selected beams.
3. Select the base point (with **Polar** mode on) anywhere in the drawing.
4. On the command line enter **2500** and press **Enter**.
Figure 40: Selecting the end point of the newly copied beams

The beams are copied 2500 distance below.

Use the options on the Viewpoints panel of the Home tab to change the view angle.

Figure 41: The final result: 6 new beams.
Step 7: Creating a curved beam

Create a curved beam between the C1 and E1 columns. The beam has an UAP150 section.

Use the Orbit tool to rotate the drawing in 3D and get a suitable position.

1. On the UCS tool palette, click to change the placement of the UCS.
2. Specify the new origin point in the upper system line end point of the C1 column.
3. On the Home tab, Objects panel, click.
4. Use the upper system line end point of the E1 column as the start point.
5. Use the upper system line end point of the C1 column as the end point of the curved beam (with Polar mode on).
6. Click in the –Y direction to define the circle point.

![Figure 43: Creating a curved beam](image)

7. In the properties dialog box define the following settings:

   On the **Section & Material** tab:

   – Use the buttons and make the following settings for the curved beam:

   ![Figure 44: Section & Material tab – Selecting the section class](image)

   On the **Positioning** tab, select the position of the beam.

   ![Figure 45: Properties dialog box – Positioning tab](image)
On the **Naming** tab:

- Set the model role to **Curved beam**.

**Figure 46: Naming tab – Selecting the model role**

**Adjusting the curved beam end point position**

Offset the curved beam end points using the grip points.

1. Select the curved beam end point from the **E1** column.
2. Move the grip point in the −X direction.
3. On the command line, enter **50** for the displacement distance.

**Figure 47: Adjusting the end point position**
Using the same process, adjust the curved beam position from the **C1** system line end point by dragging the mouse pointer in the X direction.

**Figure 48: Adjusting the curved beam end point position from the **C1** column)**

### Modifying the curved beam radius

1. Select the curved beam.
2. Right click and select **Advance Properties** from the context menu.
3. In the beam properties dialog box, on the **Positioning** tab enter **4000** for the radius:

**Figure 49: Positioning tab – Setting the curved beam radius**

**Figure 50: The **E1-C1** curved beam**
Step 8: Creating purlins

In this step, create 4 purlins with a UPN140 section between the E1-C1 straight beam and the E1-C1 curved beam.

1. On the Home tab, Objects panel, select

![Image of Objects panel]

2. Use as start point the upper system line end point of the E1 column.

![Figure 51: Selecting the start point of the channel section beam: the system line end point of the C1-E1 straight beam.]

3. Move the mouse pointer in the –Y direction (the setting Ortho causes an exact orientation entry) and enter 1400 to define the channel section beam end point.

![Figure 52: Defining the direction of the channel section beam]
4. In the beam properties dialog box, on the Section & Material tab, use the buttons and make the following settings:

![Figure 53: Section & Material tab – Selecting the section](image)

**Copying the channel section beam**

Next, copy the purlin to the 1200, 2400, 3600, 4800 distances from the first purlin in the –X direction.

1. Select the channel section beam.

2. On the Tools tool palette, click to copy the selected beam.

3. Define the reference point anywhere in the drawing.

4. Move the mouse pointer in the –X direction (the Ortho setting causes an exact orientation entry). On the command line, enter the distances: 1200, 2400, 3600, 4800. Press Enter after each one.

Delete the first created channel section beam.

![Figure 54: 4 channel section beams](image)
**Modify the position and the model role of the channel section beams**

1. Select all the channel section beams.

2. Right click and select **Advance Properties** from the context menu.

3. In the beam properties dialog box, define the following settings:
   - On the **Positioning** tab, select the position of the channel section beam.
   - On the **Naming** tab:
     - Set the model role to **Purlin**.
Adjusting the purlin position

1. Select all the channel section beams.
2. Right click and select **Move** from the context menu.
3. Specify the base point as in Figure 59 and move the purlins in the Y direction until they reach the edge of the C1-E1 straight beam.

⚠️ Make sure that the **Node** and **Perpendicular** OSNAP modes are active.

---

**Figure 58:** Activating the **Perpendicular** OSNAP mode

**Figure 59:** Adjusting the purlin position
Lesson 4: Creating structural elements

In this lesson, you will create structural elements.
You will learn to:
- Create cross bracings
- Create a joist
- Move a structural element

Step 1: Creating cross bracings
In this step, create cross bracings between the G4 and G6 columns and the B3 and B4 columns.
First, move and rotate the UCS in a suitable position:

1. On the UCS tool palette, click .
2. Specify the new origin point in the lower system line end point of the G4 column.
3. Next, rotate the UCS by X and by Y so that the Y-axis points upwards and the X-axis is in the G axis direction as in Figure 60.
4. On the Home tab, Extended modeling panel, click .
5. Use the lower system line end point of the G4 column as the base point of the area to stiffen.
6. Select the diagonal point: the upper system line end point of G5 column.

The properties dialog box appears.

**Modifying cross bracing properties**

In the structural element properties dialog box, define the following settings:

On the **Type & Section** tab:

- Select the bracing type: **Crossed**.
- Use the buttons and make the following settings:
  - Select the section class: **Flat**.
  - Select the section size: **FL100X10**.
- From the **Member split** drop-down list, select **Diagonal 1**, to split the bracing.
On the **Geometry** tab:

- Define the offset from top (upper distance): **120**.
- Define the offset from bottom (lower distance): **0**.

![Properties dialog box – Geometry tab](image)

**Figure 63:** Properties dialog box – **Geometry** tab

![The flat cross bracings](image)

**Figure 64:** The flat cross bracings

For the second cross bracing, use the tools on the **UCS** tool palette to move and rotate the UCS in a suitable position as in Figure 65. The new origin point is the lower system line end point of the **B4** column.

*Use the buttons on the **Viewpoints** panel to change the view angle.*
4. On the **Home** tab, **Extended Modeling** panel, click ![Extended Modeling Icon].

5. Use the lower system line end point of the **B4** column as the base point of the cross bracing.

6. Select the diagonal point: the upper system line end point of the **B3** column.

The properties dialog box appears.
Modifying cross bracing properties

In the structural element properties dialog box, define the following settings:

- On the **Type & Section** tab:
  - Select the bracing type: Crossed.
  - Select the section class: RHS rectangle cold.
  - Select the section size: RHS60X40X4.
  - From the **Member split** drop-down list, select Diagonal 2, to split the bracing.

![Type & Section tab - Splitting the bracing](image)

- On the **Geometry** tab:
  - Define the offset from top (upper distance): 120.
  - Define the offset from bottom (lower distance): 0.

![Properties dialog box – Geometry tab](image)
Step 2: Creating a joist

Next, create a joist between the B3 and F3 columns.

First, use the tools on the UCS tool palette to move and rotate the UCS in a suitable position as in Figure 70. The new origin point at the upper system line end point of the C1 column.

1. On the Home tab, Extended Modeling panel, click 

2. Use the upper system line end point of the B3 column as the start point of the joist.
3. Use the upper system line end point of the F3 column as the end point of the joist.

4. Move the mouse pointer in the –Z direction to define the orientation and enter 700 for the joist height.

The properties dialog box appears.

**Modifying joist properties**

In the joist properties dialog box, define the following settings:

- On the **Sections** tab:
  - Select the section class: **Angle not identical**.
  - Select the section size: **L80X40X6**.

- On the **Joist seat** tab, modify the thickness of plate 2: **10**.
• On the **Geometry** tab, modify if necessary the joist height and width.

![Properties dialog box – Geometry tab](image)

**Figure 73: Properties dialog box – Geometry tab**

• On the **Chord extension** tab, adjust the length of the chords.

![Properties dialog box – Chord extension tab](image)

**Figure 74: Properties dialog box – Chord extension tab**

**Figure 75: The joist**
Step 3: Moving the joist

You must move the joist at an 800 distance in the –Y direction to adjust to the context.

1. Select the structural element of the joist.

2. Right click and select **Move** from the context menu.

3. Define the base point anywhere in the drawing.

4. Move the mouse pointer in the –Y direction (the **Ortho** setting causes an exact orientation entry) and enter 800 for the displacement.

**Note:** For a more realistic presentation of the model, use the **Realistic** visual style.
Step 4: Other adjustments

Notice that the model is not right: the joist plate is inside the beam. To correct this situation, adjust the beam positions.

1. Select the B2-B3 and the F2-F3 beams.

2. Right click and select **Advance Properties** from the context menu.

3. In the properties dialog box, on the **Positioning** tab, define the offset value in the Z direction: -110.
For a more realistic presentation of the model, use the **Visual styles** panel.

Figure 81: The corrected model
Lesson 5: Defining model views

When working with large models with many elements an isometric view can be confusing. A model view creates local view areas that show only the elements that lie within specific boundaries. Slices are cut from the model for better visualization.

Model views are created using different definition methods. In this lesson, you will define model views:

- With 1 point in the UCS
- With 2 points in the UCS, front and rear depth
- At the selected grid line

**Note:** All the views defined in this lesson are further used in Lesson 7 – “Creating intelligent connections”.

All created views are listed in the Model views section of the Project Explorer.

The display of a model view can be turned on or off using the light bulb in front of the name. If you double click on a model view name the model view is turned on and the model rotates to the selected Default View direction.

![Figure 82: Project Explorer – Model views category](image)

For quicker access, display the Project Explorer: On the Home tab, Explore panel, click
Defining a view with 1 point in the UCS

Define a view on the E1 column and the C1-E1 straight beam, which will be connected by a clip angle in Lesson 7 – “Creating intelligent connections”.

*Use the buttons on the Viewpoints panel to change the view angle.*

1. Place the UCS in a suitable position as in Figure 83. The XY plane is in the elevation plane.

2. On the Quick views tool palette, click .

3. In the “Choose the definition method” dialog box, select the **One point in UCS** method.

Figure 83: The E1 column

Figure 84: Selecting the view definition method
4. Select the axis intersection of the E1 column and the C1-E1 straight beam.

Figure 85: The axis intersection of the E1 column and the C1-E1 straight beam

5. On the command line, enter ClipAngle for the name of the current view and press Enter.
6. Define the view direction (in this case, from the top) by selecting the top arrow and press Enter.
7. You can modify the view box size using the grips as in the following figure.

Figure 86: Modifying the view box size

The view is created and appears in the Project Explorer. Clicking the bulb displays only the ClipAngle model view.

Figure 87: Top view on the E1 column
Use the buttons on the **Viewpoints** panel to change the view angle.

Figure 88: The “Clip angle” view on the E1 column

On the **Quick views** tool palette, click ![image] to redisplay all the elements of the model or double click the view box.
Defining a view with 2 points in UCS and front and rear depth

In this step, define a view on the E1, F2 columns and the E1-F2 beam which will be used for creating the clip angle skewed connection in Lesson 7 – “Creating intelligent connections”.

Use the buttons on the Viewpoints panel to change the view angle.

1. Place the UCS in a suitable position as in the Figure 91 using UCS 3 points tool on the UCS tool palette. The XY plane is in the elevation plane.

2. On the Quick views tool palette, click
3. In the “Choose the definition method” dialog box, select the **Two points in UCS + front and rear depth** method.

![Figure 90: Selecting the view definition method](image)

4. Select the first point of the view: the exterior lower end point of the E1 column.
5. Select the second point of the view: the exterior upper end point of the F2 column.

![Figure 91: Selecting the two points defining the view](image)

6. On the command line, define the view depth:
   - Front depth: **500** and press **Enter**
   - Rear depth: **500** and press **Enter**.
7. On the command line, enter `ClipAngleSkewed` for the name of the current view and press `Enter`.

6. Define the view direction (in this case, from the top) by selecting the top arrow and press `Enter`.

![Figure 92: ClipAngleSkewed view in top view](image)

The view is created and appears in the Project Explorer. Clicking the light bulb displays only the ClipAngleSkewed model view.

![Figure 93: Project Explorer – ClipAngleSkewed view](image)

**Tip:** The view box can be enlarged using the grip points. Right click and select `Activate` from the context menu to view the result.

![Figure 94: Resizing the view](image)
Use the buttons on the **Viewpoints** panel to change the view angle.

![Viewpoints panel]

Figure 95: The "ClipAngleSkewed" view on the E1 and F2 columns

On the **Quick views** tool palette, click ![Quick view button] to redisplay all the elements of the model or double click the view box.

**Defining a view at a grid line**

Define a view on the C6, D6 rectangular columns and the A6-G6 beam, which will be used for creating gable wall and front plate splice connections in Lesson 7 – “Creating intelligent connections”.

*Use the buttons on the **Viewpoints** panel to change the view angle.*
1. On the **Quick views** tool palette, click ![Quick views](image)

2. In the “Choose the definition method” dialog box, select **At a grid line** method.

![Choose the definition method](image)

**Figure 96:** Selecting the view definition method

3. Select the grid line labeled with **6** and press **Enter**.

4. On the command line, enter **GableWall** for the name of the current view and press **Enter**.

![GableWall view](image)

**Figure 97:** GableWall view

5. Define the view direction by selecting the left arrow and press **Enter**.

The view is created and appears in the Project Explorer. Clicking the light bulb displays only the GableWall model view.

*Use the buttons on the Viewpoints panel to change the view angle.*

![Viewpoints panel](image)

**Figure 98:** The “GableWall” view on the C6 and D6 columns
On the **Quick views** tool palette, click to redisplay all the elements of the model or double click the view frame.

If necessary, the view boxes can be hidden using the "Selected objects off" tool.
Lesson 6: Working with intelligent connections

In this lesson you will create base plates for all columns of the model and end plate connections between beams and columns.

You will learn how to:
- Create simple connections – a base plate connection and a single side endplate connection
- Modify the connection properties
- Handle several similar connections using groups of connections
- Defining the master connections
- Creating slave connections
- Adding connections to an existing group
- Removing a connection from a group of connections
- Create other connections by template

Concepts

Joints

Joints are intelligent connections that consist of basic elements such as plates, stiffeners, beams, bolts and welds and dependent elements (shortenings, copes) controlled by construction rules. An Advance joint is created with all its parts and features using a single operation.

A joint is represented in the model by a gray box connection object that contains all the connection parts. Joints are available in the Connection vault which is accessible from the Extended modeling panel of the Home tab.

Figure 99: Accessing Connection vault

Joint group

Sometimes it is useful to link several joints together so that if one changes all other joints change and continue to match.

In a joint group one joint is the master and the other joints in the group are slaves and must always match the master. Any changes to the master joint are immediately applied to all slave joints.

In the joint properties dialog box of a slave joint all controls are disabled to prevent editing.
Step 1: Creating a base plate joint

In this step, create a base plate with 4 bolts for the C1 column.

Use the buttons on the Viewpoints panel to change the view angle.

1. On the UCS tool palette, click 🔄.
2. Specify the new origin point in the A1 axis intersection.
3. Next, rotate the UCS by X and by Y so that the XY plane is in the grid plane as in Figure 100.

Figure 100: Placing the UCS in a suitable position

4. Open the Connection vault: On the Home tab, Extended modeling panel, click 🔄.
5. From the Base plates category, click 🔄.
6. Select the C1 column and press Enter.
The base plate with anchor bolts is created at the end of the column. The plate is welded to the column. The properties dialog box appears.

**Step 2: Creating a group of base plate connections**

In this step, the base plate created for the C1 column is defined as the master connection for other base plates in new locations.

**Defining the master connection**

The connection between the master connections and the slave joints is made through the name of the master connection.

**Note:** The name of the master connection must be unique. The slave connections receive the same name automatically.

1. Select any part of the C1 base plate joint, for example the plate.
2. Right click and select **Advance joint properties** from the context menu.
3. In the properties dialog box, in the Name field, enter the name of the master connection.

![Figure 101: Defining the master connection](image)

**Creating slave connections**

In this step, the base plate created for the C1 column is used as template for other base plates in new locations.

1. On the **Extended modeling** tab, **Joint Utilities** panel, click [button].
2. Select any part of the template joint (e.g. the plate of the C1 base plate joint) and press Enter.

![Figure 102: Selecting the base plate](image)

3. One by one, select the columns to which the base plate will be copied and right click after each one (all columns of the model).

The base plates are created on the selected columns.

**Note:** Notice that the columns along the 6 axes differ in geometry from the other columns from the model (have a square section) and the plate size is according to the column section (Figure 104). In this case, the slave joints are not the same as the master connection and cannot be part of the group.

4. Click Yes in the warning message box.

![Figure 103: Warning message box](image)

The slave joints receive the same name automatically.

The base plates of the square columns are separated from the joint group. As the columns have the same section, the connections can be part of another group.

*For a more realistic presentation of the model, use the Realistic visual style.*

![Figure 104: Base plate for the square section columns](image)
To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

**Step 3: Adding a connection to an existing group**

In this step, the base plates created for the column along the 6 axes will be grouped. Define the **A6** base plate as the master connection by setting a name in the properties dialog box.

1. On the **Extended modeling** tab, **Joint Utilities** panel, click \[Image\].
2. Select the joint to add to the new group – the base plate of the **C6** column – and press **Enter**.
3. Select the master joint – the base plate of the **A6** column – and press **Enter**.

Using the same process, add the base plates of the **D6** and **G6** columns to the group.

The four connections are linked. Any modification in the master connection is transferred immediately to all the connections in the group.
Step 4: Removing a joint from a joint group
In this step, the B3 and B4 base plate joints will be removed from the group. This will allow editing them independently from other joints of the group.

1. On the Extended modeling tab, Joint Utilities panel, click .

2. Select any part of the joint to be removed from the group, in this case, the B4 base plate and press Enter.

The B4 base plate joint is no longer part of the group. The properties can be changed independently from the group.

Using the same process, remove the B3 base plate connection from the group.

Step 5: Modifying the properties of a simple joint
In this step, create asymmetrical base plates of the B3 and B4 columns by modifying the base plate size, the bolt properties, the number of bolt lines and columns.

Creating an asymmetrical base plate
Modify the size of the base plate.

1. Select any part of the B4 base plate.
2. Right click and select Advance Joint Properties from the context menu.
3. In the properties dialog box, select the **Base plate** category and define the following settings:

On the **Base plate layout** tab:

− Define the plate thickness: **20**.

![Figure 108: Properties dialog box – Base plate layout tab](image)

On the **Base plate dimensions** tab:

− As the base plate is not symmetric, unselect **All projections equal**.
− Set the Projection 1, 2 and 3 to **30**.
− Set the Projection 3 value to **200**.

![Figure 109: Properties dialog box – Base plate dimensions tab](image)

On the **Anchor and holes** tab:

− Select the anchor diameter: **20.00 mm**.

![Figure 110: Properties dialog box – Anchor and holes tab](image)

On the **Anchors parallel web** tab:

− Define the number of bolt lines in the first group (parallel to the column’s web): **2**.
− Define the distance between the bolt lines: **100**.
− Define the offset from the center of the beam section: **0**.

![Figure 111: Properties dialog box – Anchors parallel web tab](image)
On the Anchors parallel flange tab:

- Define the number of bolt lines (parallel to the beam’s flange): 2.
- Define the intermediate distance between bolt lines: 120.
- Define the offset from the center of the beam section: 0.

Figure 112: Properties dialog box – Anchors parallel flange tab

For a more realistic presentation of the model, use the Realistic visual style.

Figure 113: The asymmetrical base plate

Figure 114: Asymmetrical base plate of the B4 column
Using a similar process, define the same properties for the B3 base plate joint:

- On the **Base plate dimensions** tab:
  - Set the Projection 4 value to **200**.
  - Set the Projection 3 value to **30**.

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

**Step 6: Modifying joint properties within a group**

Next, modify the base plate size, the bolt properties, the number of bolt lines and columns. The modifications will be transferred automatically to the other joints of the group.

To change the properties of joints of a group the master joint must be modified as all editing of slave joints is disabled. However you may not know which joint is the master.

There are two methods to modify the properties of grouped joints:

- Use the **Search filter** to search the master joint and modify the properties.

- Access the properties of any joint of the group and enable **Upgrade to master** option on the **Properties** tab. The current joint becomes the master of the group and any of its properties can be modified in the current dialog box.
1. Select any part of a base plate joint, for example the plate of the E1 base plate joint.
2. Right click and select **Advance Joint Properties** from the context menu.

**Note:** Notice that in the properties dialog box all controls are grayed as the E1 base plate joint is not the master joint in the group.

3. In the properties dialog box, on the **Properties** tab, enable **Upgrade to master**. The E1 base plate becomes the master joint of the group and its properties can be modified.

![Figure 117: Upgrading the joint to master](image)

4. Select the **Base plate** category and define the following settings:
   
   On the **Base plate layout** tab:
   
   - Define the plate thickness: **20**.
   - From the **Layout** drop-down list, select **projections** to calculate the base plate length according to the set projections.
   - From the **Column shortening** drop-down list, select **plate thickness** to shorten the column by the plate thickness.

![Figure 118: Properties dialog box – Base plate layout tab](image)

   On the **Base plate dimensions** tab:
   
   - Select **All projections equal** to define the plate size by equal projections.
   - Define the projection value: **30**.

![Figure 119: Properties dialog box – Base plate dimensions tab](image)
On the **Anchor and holes** tab:
- Select the anchor diameter: **20.00 mm**.

![Figure 120: Properties dialog box – Anchor and holes tab](image)

On the **Anchors parallel web** tab:
- Define the number of bolt lines in the first group (parallel to the column’s web): **2**.
- Define the distance between the bolt lines: **100**.
- Define the offset from the center of the beam section: **0**.

![Figure 121: Properties dialog box – Anchors parallel web tab](image)

On the **Anchors parallel flange** tab:
- Define the number of bolt lines (parallel to the beam's flange): **2**.
- Define the intermediate distance between bolt lines: **120**.
- Define the offset from the center of the beam section: **0**.

![Figure 122: Properties dialog box – Anchors parallel flange tab](image)

Figure 123: The base plate

The modifications are transferred automatically to the other base plate joints from the group.
View the result

For a more realistic presentation of the model, use the **Realistic** visual style.

![Figure 124: Base plate joint in shaded mode](image)

**Note:** If the bolts have the Standard representation, for a clear view, display the bolts in the solid representation:

1. Select the anchor bolts.
2. Right click and select **Advance Properties** from the context menu.
3. In the properties dialog box, on the **Display type** tab, select the **Solids** option.

![Figure 125: Displaying bolts in the solid representation](image)

Using a similar process, modify the base plate size and the distances between the bolts of the A6 base plate joint to match the square section column. The modifications will be transferred automatically to the other three joints of the group.

**To cancel the shading, click the 2D Wireframe option on the Visual styles panel.**
In the properties dialog box, select the **Base plate** category and define the following settings:

- **On the Base plate layout tab:**
  - Define the plate thickness: **20**.
  - From the **Layout** drop-down list, select **projections** to calculate the base plate length according to the set projections.
  - From the **Column shortening** drop-down list, select **plate thickness** to shorten the column by the plate thickness.

  ![Figure 127: Base plate thickness](image)

- **On the Base plate dimensions tab:**
  - Modify the Projection 1 value to **80**.

**Note:** As the base plate is symmetrically placed, **All projections equal** option is selected.

![Figure 128: Properties dialog box – Base plate dimension tab](image)

- **On the Anchors parallel web tab:**
  - Define the distance between bolt columns: **200**.

![Figure 129: Properties dialog box – Anchors parallel web tab](image)
- On the **Anchors parallel flange** tab:
  - Define the distance between bolt lines: **150**.

  ![Figure 130: Properties dialog box – Anchors parallel flange tab](image)

For a more realistic presentation of the model, use the **Realistic** visual style.

![Figure 131: The base plate modified for the square section column](image)

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.
Step 7: Creating independent joints of the same type
This step describes how to connect a column to a beam using single side end plate connections. Create several single side end plate joints in the model starting from the A4 column.

Creating single side end plates

1. Open the Connection vault: On the Home tab, Extended modeling panel, click $\text{Connection vault}$.

2. From the Plate joints category, click $\text{Plate joints}$.

3. Select the A4 column and press Enter.

4. Select the upper A4-B4 beam and press Enter.

4. Click OK in the “Attention” dialog box.

The joint is created and the beam is connected by a plate to the flange of the column. The properties dialog box appears.
Modifying single side end plate properties

In the properties dialog box, select the Plate & bolts category and define the following settings:

- On the **Horizontal bolts** tab modify the distance between the bolt columns:
  - Unselect the **Bolts on gauge lines** option.
  - In the **Center distance** field enter **75**.

- On the **Vertical bolts** tab modify the plate height according to the number of bolts and the distance between them:
  - From the **1. Layout** drop-down list select **Plate 1** as reference for the bolt distances.
  - Define the **Plate height** by **Bolt distances from the top** edge of the plate.
  - Define the plate layout distance: **0**.
  - Define the number of bolt lines in the first group: **3**.
  - Define the first bolt distance to the plate edge: **60**.
  - Define the distance between the bolt lines within the group: **80**.
  - Define the end distance: **60**.

The plate height is automatically calculated (**3. Plate height** field).

For a more realistic presentation of the model, use the **Realistic** visual style.
Note: For a clear view, display the bolts in the solid representation:

![Image of single side end plate in shade mode, with bolts in solid view](image)

Figure 136: Single side end plate in shade mode, with bolts in solid view

To cancel the shading, click the 2D Wireframe option on the Visual styles panel.

Creating by template single side end plates

1. On the Extended modeling tab, Joint Utilities panel, click

2. Select any part of the template joint (e.g. the plate of the upper A4-B4 joint) and press Enter.
3. Select the column to which the beam is connected through a single side end plate: the A4 column.
4. Select the beam to connect to the column: the A4-A5 upper beam.

For a more realistic presentation of the model, use the Realistic visual style.

![Image of single side end plate connections](image)

Figure 137: Single side end plate connections

Note: All the joints remain independent of each other.
Using the same process, create single side end plates between:

- The A4 column and:
  - The A4-A5 middle beam
  - The A4-B4 middle beam
- The B4 column and:
  - The B4- A4 middle beam
  - The B4- G4 beam
  - The B4- A4 upper beam
  - The B4 - B3 upper beam
- The B2 column and the B2-B3 beam

Figure 138: Joint locations in the model

Use the buttons on the Viewpoints panel to change the view angle.

Using the same process, create the single side end plates between:

- The F2 column and:
  - The F2-F3 beam
- The F3 column and:
  - The F3-F2 upper beam
  - The F3-G3 upper beam
  - The F3-G3 middle beam
- The G3 column and:
  - The G3-F3 upper beam
  - The G3-G4 upper beam
  - The G3-F3 middle beam
  - The G3-G4 middle beam
- The G4 column and:
  - The G4-B4 upper beam
  - The G4-G3 middle beam
- The G5 column and:
  - The G5-G6 middle beam

Figure 139: Joint locations in the model
Lesson 7: Creating intelligent connections

In this lesson, you will create various connections:

- Double side end plates
- Gable wall end plates
- Front plate splices
- Clip angles
- Clip angles skewed
- Copes
- Purlin connection elements
- Flat bracings with tension bolt and base plate
- Middle gusset plate
- Tube connection with sandwich plates
- Tube connection middle with sandwich plate

Step 1: Creating a moment end plate

Next, connect the C1-E1 curved beam to the C1 and E1 columns using moment end plates connections.

Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.

Figure 140: Moment end plate – joint location in the model
1. Open the Connection vault: On the Home tab, Extended modeling panel, click

2. From the Plate joints category, click

3. Select the C1 column and press Enter.
4. Select the E1-C1 curved beam and press Enter.
5. Click OK in the “Attention” dialog box.

The joint is created and the beam is connected by a plate to the flange of the column.

The properties dialog box appears.

**Modifying moment end plate properties**

In the properties dialog box, select the Plate & bolts category and define the following settings:

- On the Plate layout tab define the plate height by bolts:
  - Define the plate thickness: 15.
  - Select the plate height layout by bolts.
  - Enter 50 for the top and bottom edge distance.

- On the Horizontal bolts tab:
  - Define the center distance: 100.
  - Define the edge distance / Proj. 1: 30.
  - Define the edge distance / Proj. 2: 30.
  - Define the offset from center: 20.
On the **Vertical bolts** tab define the number of bolt lines and the distances between bolts:

- Define the layout distance: **0**.
- Define the number of bolt lines in the first group: **2**.
- Define the distance to the plate edge for the first bolt: **50**.
- Define the distance between bolt lines within the group: **80**.

![Properties dialog box – Vertical bolts tab](image)

**Figure 143:** Properties dialog box – **Vertical bolts** tab

**Note:** For a clear view, display the bolts in the solid representation.

**For a more realistic presentation of the model, use the **Realistic** visual style.**

![Displaying the connection in shade mode, with bolts in the solid representation](image)

**Figure 144:** Displaying the connection in shade mode, with bolts in the solid representation

**To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.**

Using the same process, create a moment end plate between the **E1** column and the **E1-C1** curved beam.
**Note:** In the moment end plate properties dialog box, on the **Horizontal bolts** tab, change the offset from center to -20.

---

**Step 2: Creating double side end plates with safety bolts**

Connect the **B3** column with the two rafters by a double side end plate with safety bolts.

*Use the buttons on the Viewpoints panel to change the view angle.*

---

1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click ![Connection vault](image).
2. From the **Plate joints** category, click ![Plate joints](image)

---

---
3. Select the B3 column and press **Enter**.
4. Select the B3-B4 beam and press **Enter**.
5. Select the B3-B2 beam and press **Enter**.

![Figure 147: Creating a double side end plate connection](image)

6. Click **OK** in the “Attention” dialog box.
   The joint is created and the beams are connected. The properties dialog box appears.

**Modifying double side end plate properties**

In the properties dialog box, select the **Plate & bolts** category and define the following settings:

- **On the Plate-Alignment tab**, enter **15** for the thickness of each plate.

![Figure 148: Properties dialog box – Plate - Alignment tab](image)

- **On the Vertical bolts tab** define the plate height by bolt distances, from the top edge of the first plate:
  - From the **Layout** drop-down list, select **Plate 1**.
  - From the **Plate height by** drop-down list, select **Bolt Distances from top**.
  - In the **Layout distance** field, enter **0** to align the plate to the top edge.

Then define the bolt distances:
  - Define the number of bolt lines in each group: **1**, for the first group, **2** for the second.
  - Define the distance to the plate edge for the first group: **60**.
  - Define the distance of the upper bolt line of the second group to the last bolt line of the previous bolt group: **110**.
  - Define the distance between bolt lines within the groups: **160** for the first group, **160** for the second.
  - Define the last bolt distance to the bottom edge of the plate: **60**.
Using a similar process, create another double side end plate connection between the A5 column and the A5-A6 and A5-A4 upper beams. The vertical distances between bolts must be modified to adjust the plate height.
In the properties dialog box, define the following settings:

- **On the Vertical bolts tab:**
  - Define the number of bolt lines in the first group: 3.
  - Define the distance to the plate edge for the first group: 60.
  - Define the distance between bolt lines within the group: 80.
  - Define the end distance: 60.

![Properties dialog box – Vertical bolts tab](image)

**Creating by template double side end plates**

Next, create by template other double side end plate connections in the locations indicated in Figure 153.

- The A5 column and:
  - A4-A5 and A5-A6 middle beams
- The G4 column and:
  - G4-G3 and G4-G5 upper beams
- The G5 column and:
  - G5-G4 and G5-G6 upper beams

![Joint location in the model](image)
Step 3: Creating gable wall end plates

In this step, create gable wall end plates at the C6 and D6 columns.

Before starting

For a clear view, use the GableWall view defined in Lesson 5 – “Defining model views”.
From the Project Explorer enable the GableWall view.

Use the buttons on the Viewpoints panel to change the view angle.

1. Open the Connection vault: On the Home tab, Extended modeling panel, click

2. From the Cantilever beam to column category, click

3. Select the G6-D6 rafter and press Enter.

4. Select the D6 column and press Enter.
5. Click **OK** in the “Attention” dialog box.

The gable wall end plate connection is created and the properties dialog box appears.

### Modifying gable wall end plates properties

In the properties dialog box, define the following settings:

- **On the Plate tab:**
  - Define the cover plate thickness: **15**.
  - Define the Projection 2 value: **100**.

- **On the Bolts & Holes tab:**
  - Select the diameter of the bolts: **12 mm**.
• On the **Bolt distances** tab:

**Note:** The **On gauge line** option must be unselected!

- Define the intermediate distance in the X direction: **220**.
- Define the intermediate distance in the Y direction: **80**.

![Figure 158: The distances between bolts in the Bolt distances tab](image)

Using the same process, create another gable wall end plate connection for the **C6** column and the corresponding rafter.

*For a more realistic presentation of the model, use the **Realistic** visual style.*

![Realistic visual style](image)

*Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.*
Note: For a clear view, display the bolts in the solid representation.

Figure 160: Displaying the joint in shade mode, with bolts in the solid representation

To cancel the shading, click the 2D Wireframe option on the Visual styles panel.

Step 4: Creating front plate splices
In this step, create front plate splice connections at the two splitting points of the A6-G6 rafter.

Note: Use the GableWall view from Lesson 5 – “Defining model views” - for a clearer display of the working area.

Figure 161: Joint location in the model
1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click ![Connection vault](image).

2. From the **Beam end to end** category, click ![Beam end to end](image).

3. Select the **D6-G6 rafter** and press **Enter**.

4. Select the **D6-C6 rafter** and press **Enter**.

5. Click **OK** in the “Attention” dialog box.

The joint is created and the rafters are connected. The properties dialog box appears.

**Modifying front plate splice properties**

Next, modify the plate size, the thickness and the bolt distances.

In the properties dialog box, define the following settings:

- On the **Plate 1** tab, define the plate size:
  - Thickness: **15**
  - Width: **150**
  - Height: **310**

![Make sure the Same as other option is enabled in the Plate 2 tab.](image)
On the Plate layout tab:
- Define the clearance between the plates: 0.

![Figure 164: Properties dialog box – Plate layout tab](image)

On the Bolt groups tab:
- Define the number of bolts per side: 1.
- Define the gauge distance: 90.
- Define the number of bolt lines in the first group: 3.
- Define the distance to the plate edge for the first group: 60.
- Define the distance between bolt lines within the first group: 80.

![Figure 165: Bolts distances on the Bolt groups tab](image)

Next, create by template another front plate splice connection between the C6-D6 rafter and the C6-A6 rafter.

![Figure 166: The front plate splice connection](image)
For a more realistic presentation of the model, use the **Realistic** visual style.

![Realistic Visual Style]

**Note:** For a clear view, display the bolts in the solid representation.

![Displaying the connection in shade mode, with bolts in the solid representation]

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

**Step 5: Creating clip angle joints**

In this step, connect the **E1 – C1** straight beam to the **E1** and **C1** columns using clip angle connections.

**Before starting**

Use the **ClipAngle** view defined in the “Lesson 5 – “Defining model views” - for a clearer display of the working area.
Use the buttons on the **Viewpoints** panel to change the view angle.

![Viewpoints panel](image)

Figure 169: Joint location in the model

1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click [button].
2. From the **Clip angle joints** category, click [button].
3. Select the **E1** column and press **Enter**.
4. Select the **E1-C1** straight beam and press **Enter**.
5. Click **OK** in the “Attention” dialog box.

The joint is created and the beams are connected by two clip angles.
Modifying clip angle joint properties

Next, modify the connection properties so that the two non-identical clip angles are connected with three bolts to the column and the beam.

In the properties dialog box, define the following settings:

- **On the Angle cleat tab:**
  - Select the angle section class: **Angle not identical**.
  - Select the angle section size: **L130X65X12**.
  - From the Long leg side drop-down list, select **secondary** to place the long leg on the beam.
  - Define the cut back value: **10**.

- **On the Bolt parameters tab:**
  - Select the diameter of the bolts: **12 mm**.

- **On the Horizontal bolts tab:**
  - In both Number per cleat fields enter **1** to connect the clip angle to each connection member by one column of bolts.
  - Select the back mark for the main beam: **80**.
  - Select the back mark for the second beam: **85**.
• On the **Vertical bolts** tab:
  - Define the set out distance: **45**.
  - Define the number of bolt lines within the first group: **3**.
  - Define the distance to the plate edge for the first group: **30**.
  - Define the distance of the upper bolt line of the group to the last bolt line of the previous bolt group: **70**.
  - Define the end distance: **30**.

The angle cleat height is adjusted according to the bolt distances.

![Figure 173: Bolts vertical distances on the Vertical bolts tab](image)

---

**For a more realistic presentation of the model, use the **Realistic** visual style.**

![Realistic visual style](image)

---

**Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.**

![Real-Time Sphere](image)
**Note:** For a clear view, display the bolts in the solid representation.

![Figure 174: Displaying the joint in shade mode, with bolts in the solid representation](image)

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

On the Project Explorer toolbar, click ![image](image) to redisplay all the elements of the model.

Using the same process (or by template), create another connection between the C1 and E1 – C1 straight beam.

![Figure 175: Joints locations in the model](image)

Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.
Using the same process, create another clip angle connection between the G6 column and the G6 – G5 upper beam. Next, change the connection settings so that the clip angles are welded to the column and bolted to the beam.

**Figure 176: Clip angle locations in the model**

In the properties dialog box, define the following settings:

- **On the Angle cleat tab:**
  - From the **Number of angles** drop-down list, select **double**.
  - Select the angle size profile: L75X55X5.
  - Define the cut back value: 10.

**Figure 177: Properties dialog box – Angle cleat tab**

- **On the Cleat weld tab:**
  - From the **Welded at** drop-down list, select **main**.

**Figure 178: Properties dialog box – Cleat weld tab**

- **On the Bolt parameters tab:**
  - Select the bolt diameter: 16.

**Figure 179: Properties dialog box – Bolt parameters tab**
• On the **Horizontal bolts** tab, define the number of bolt lines connecting the clip angle to the beam and their position:
  − Define the back mark at the secondary beam: **45**.
  − In the **6. Number per cleat** field define the number of bolt lines on the secondary member: **1**.

![Horizontal bolts tab](image)

Figure 180: Properties dialog box – **Horizontal bolts** tab

• On the **Vertical bolts** tab:
  − Define the set out distance: **75**, from the clip angle.
  − Define the number of bolt lines in the first group: **3**.
  − Define the distance to the first bolt of the group: **25**.
  − Define the distance between bolt lines within the group: **50**.
  − Define the edge distance: **25**.

The length of the clip angle is automatically calculated according to the bolt distances.

![Vertical bolts tab](image)

Figure 181: Properties dialog box – **Vertical bolts** tab

---

*For a more realistic presentation of the model, use the **Realistic** visual style.*

![Realistic visual style](image)

Figure 182: The clip angle joint in shade mode
To cancel the shading, click the 2D Wireframe option on the Visual styles panel.

Next, create by template all other clip angle connections between:
- The **G6** column and:
  - The **G6-F6** upper beam
  - The **G6-G5** middle beam
- The **A6** column and:
  - The **A6-A5** upper beam
  - The **A6-B6** upper beam
  - The **A6-A5** middle beam

**Step 6: Creating a clip angle skewed joint**

In this step, create a connection with a folded clip angle. The attached beam is skewed to the main one.

**Before starting**

Use the ClipAngleSkewed view from Lesson 5 – “Defining model views” - for a clearer display of the working area.
Use the buttons on the Viewpoints panel to change the view angle.

![Viewpoints panel](image)

1. Open the Connection vault: On the Home tab, Extended modeling panel, click [Connection vault].

2. From the Clip angle joints category, click [Clip angle joints].

3. Select the E1 column and press Enter.
4. Select the E1-F2 beam and press Enter.
5. Click OK in the “Attention” dialog box.

The joint is created and the beams are connected. The properties dialog box appears.

**Modifying clip angle skewed joint properties**

Next, adjust the cleat position according to the context and create a connection welded to the column and bolted to the skewed rafter (one bolt columns).

In the properties dialog box, define the following settings:

- On the Cleat weld tab:
  - Select Connect on other side to create the clip angle on the correct side.
  - From the Welded at drop-down list, select main.

![Properties dialog box – Cleat weld tab](image)
On the **Angle cleat** tab:
- Select 7. **Cut parallel** option to cut the secondary beam parallel with the main beam section.
- Select the number of angles: **double**.
- Define the thickness of the angles: **10**.
- Define the clip leg length at column: **60**.
- Define the leg length at beam: **150**.
- Define the cut back distance: **10**.

![Figure 187: Properties dialog box – Angle cleat tab](image)

On the **Horizontal bolts** tab, define the number of bolt lines connecting the clip angle to the beam and their position:
- From the **Set out at main** drop-down list, select **total**.
- Define back mark at secondary member: **80**.
- In the **6. Number per cleat** field define the number of bolt columns on the secondary member: **1**.

![Figure 188: Properties dialog box – Horizontal bolts tab](image)

On the **Vertical bolts** tab, adjust the clip angle position relative to the secondary beam, then set the number of bolts and the distances between them:
- From the **Set out** drop-down list, select **Angle from sec**.
- Define the set out distance: **50**.
- Define the number of bolt lines in the first group: **3**.
- Define the distance to the plate edge from the first bolt of the group: **25**.
- Define the distance between bolt lines within the group: **70**.
- Define the end distance: **25**.

The length of the folded cleat is automatically calculated according to the bolt distances.

![Figure 189: Properties dialog box – Vertical bolts tab](image)
For a more realistic presentation of the model, use the **Realistic** visual style.

Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.

**Note:** For a clear view, display the bolts in the solid representation.

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

On the Project Explorer toolbar, click to redisplay all the elements of the model.
Creating by template clip angle skewed joints

Next, create by template all other clip angle skewed connections between:

- The F2 column and the F2 – F1 beam
- The C1 column and the C1-B2 beam
- The B2 column and the C1-B2 beam

Step 7: Creating copes

In this step, create copes on each purlin according to the C1-E1 curved beam. The purlins should be welded to the beam.

Use the buttons on the Viewpoints panel to change the view angle.

Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.
1. On the **Beam features** tool palette, click ![Beam Features Icon].
2. Select the **C1-E1** curved beam and press **Enter**.
3. Select a purlin (for example, the first purlin) and press **Enter**.
4. Click **OK** in the “Attention” dialog box.
   The purlin is coped.
5. In the properties dialog box, on the **Welds** tab, select the **Create weld** option.

![Figure 193: Creating a welded connection](image)

Using a similar process, create a processing for each purlin.

**For a more realistic presentation of the model, use the **Realistic** visual style.**

![Figure 194: The model in shade mode](image)

**To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.**
Step 8: Creating purlin connections

In this step, connect each purlin to the C1-E1 straight beam.

1. Open the Connection vault: On the Home tab, Extended modeling panel, click [ ].
2. From the Generic purlin joints category, click [ ].
3. Select the C1-E1 straight beam and press Enter.
4. Select a purlin (e.g., the first purlin) and press Enter.
5. Click OK in the “Attention” dialog box.

The purlin is connected and the properties dialog box appears.

Modifying purlin connection elements properties

In the properties dialog box, define the following settings:

- On the Structural parts tab, select the Use folded beam as purlin shoe option to use a folded beam as purlin shoe.
- On the Connection tab, select the diameter of the bolts: 12 mm.
• On the **Distances** tab:
  - From the **Purlin shoe position** drop-down list, select **other side** to place the connection element correctly.
  - Define the distance from the section origin to the bolt connecting the element with the purlin: **70**.
  - Define the bolt distance to the purlin shoe edge: **35**.
  - Define the distance between the two bolts at purlin: **70**.
  - Define the distance between the two bolts at main beam: **80**.

**Figure 198: Properties dialog box — Distances tab**

**Note:** For a clear view, display the bolts in the solid representation.

**Figure 199: The purlin connections with bolts in the solid representation**

Next, create by template all other purlin connections.

*For a more realistic presentation of the model, use the **Realistic** visual style.*

**Figure 200: Purlin connections**
To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

**Step 9: Creating a flat bracing with tension bolt for a base plate**

In this step, create flat bracings with tension bolts at the base plate of the **G4** and **G5** columns in the location indicated in Figure 201.

*Use the buttons on the **Viewpoints** panel to change the view angle.*

1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click

2. From the **General bracings** category, click
3. Select the **G4** column and press **Enter**.
4. Select the base plate and press **Enter**.
5. Select the bracing and press **Enter**.

![Figure 202: Selecting the elements to connect](image)

6. Click **OK** in the “Attention” dialog box.

The joint is created and the properties dialog box appears.

**Modifying flat bracing with tension bolt and base plate properties**

In the properties dialog box, select the **General** category and define the following settings:

- **On the **Gusset plate shape** tab:**
  - From the **Shape** drop-down list, select the shape of the gusset plate: **two chamfer**.
  - Select the **Aligned to base plate** option to align the gusset plate to the base plate.

![Figure 203: Properties dialog box – Gusset plate shape tab](image)

- **On the **Gusset plate contour** tab:**

![Figure 204: Properties dialog box – Gusset plate contour tab](image)
• On the **Angle** tab:
  - Select the angle section class: **Angle identical**.
  - Select the angle section size: **L100X10**.

![Figure 205: Properties dialog box – Angle tab](image)

For a more realistic presentation of the model, use the **Realistic** visual style.

![Figure 206: The flat bracing connection in shade mode](image)

Next, create by template another flat bracing with tension bolt connection between the **G5** column, the base plate and the **G5 – G4** bracing.

![Figure 207: The two connections](image)

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.
Step 10: Creating a flat bracing with tension bolt for a beam

Use the same joint (flat bracing with tension bolts) to connect the G4 and G5 columns with the bracings and the G4 – G5 beam.

1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click **Connection vault**.

2. From the **General bracings** category, click **Flat bracing with tension bolt**.

3. Select the G4 column and press **Enter**.

4. Select the beam and press **Enter**.

5. Select the bracing and press **Enter**.
6. Click **OK** in the “Attention” dialog box.

The properties dialog box appears.

**Modifying flat bracing with tension bolt and base plate properties**

In the properties dialog box, select the **General** category and define the following settings:

- On the **Gusset plate shape** tab, select the shape of the gusset plate: **two chamfer**.

  ![Figure 210: Properties dialog box – Gusset plate shape tab](image)

- On the **Angle** tab, define the angle distance from the column: **100**.

  ![Figure 211: Properties dialog box – Angle tab](image)
Create by template another flat bracing with tension bolt between the G5 column, the G5 - G4 beam and the bracing.

For a more realistic presentation of the model, use the Realistic visual style.
To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

**Step 11: Creating middle gusset plates**

In this step, connect the bracings between the **G4** and **G5** columns by a middle gusset plate.

**Before starting**

*Use the buttons on the **Viewpoints** panel to change the view angle.*

![Diagram of the joint location in the model](image)

Figure 214: The joint location in the model

1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click 🔎.
2. From the **General bracings** category, click ️.
3. Select the continuous diagonal and press **Enter**.

![Figure 215: Selecting the continuous bracing](image)

4. Select one of the two split beams and press **Enter**.

5. Select the other split beam and press **Enter**.

![Figure 216: Selecting the elements to connect](image)

6. Click **OK** in the “Attention” dialog box.

   The joint is created and the properties dialog box appears.

![Figure 217: The middle gusset plate connection](image)
Step 12: Creating a tube connection with sandwich plates for the base plate

In this step, create a tube connection with sandwich plates to connect the B3 and B4 columns with the base plates and the bracings. A similar joint connects the B3 – B4 beam with the end plate (from the double side connection) and the bracing.

Before starting

Use the buttons on the Viewpoints panel to change the view angle.

1. Open the Connection vault: On the Home tab, Extended modeling panel, click .
2. From the Tube joints category, click .

![Figure 218: Joints locations in the model]
3. Select the B4 column and press **Enter**.
4. Select the base plate and press **Enter**.
5. Select the bracing and press **Enter**.

6. Click **OK** in the “Attention” dialog box.

   The properties dialog box appears.

**Modifying the tube connection with sandwich plates properties**

In the properties dialog box, select the **General** category and define the following settings:

- On the **Gusset plate shape** tab:
  - From the **1. Shape at column** drop-down list select **perpendicular** to create the top edge of the plate perpendicular on the column.
  - Select the **Aligned to base plate** option to align the gusset plate to the base plate.
On the **Gusset plate contour** tab:
- From the **Corner type** drop-down list, select **Corner finish**.
- From the **Corner finish** drop-down list, select **straight**.
- Define the corner size: 10.

![Figure 221: Properties dialog box – Gusset plate corner tab](image)

On the **Tab plate** tab define the tab plate size and the slot length:
- Define the cut back layout as 100 from the last bolt.
- From the **Width layout** drop-down list, select **total**.
- Define the width value: 120.

![Figure 222: Properties dialog box – Tab plate tab](image)

Next, create by template another Tube connection with sandwich plates connection for the B3 column with the base plate and the bracing.

*For a more realistic presentation of the model, use the **Realistic** visual style.*

![Figure 223: Tube connection with sandwich plates joint – shade mode](image)
To cancel the shading, click the 2D Wireframe option on the Visual styles panel.

Using a similar process, create another tube connection with sandwich plate connecting the B3 – B4 column with the end plate (from the double side connection) and the bracing.

1. Open the Connection vault: On the Home tab, Extended modeling panel, click  
2. From the Tube joints category, click  
3. Select the B3-B4 rafter and press Enter.
4. Select the side end plate and press Enter.
5. Select the bracing and press Enter.
6. Click OK in the “Attention” dialog box.

The joint is created and the properties dialog box appears.
Modifying the properties

In the properties dialog box, select the **General** category and define the following settings:

- **On the Gusset plate shape tab:**
  - From the **Shape at column** drop-down list, select *variable*.
  - From the **Shape at beam/plate** drop-down list, select *variable*.
  - Select the **Align to base plate** option to align the gusset plate edge to the side end plate.

![Figure 225: Properties dialog box – Gusset plate shape tab](image)

- **On the Gusset plate contour tab:**
  - From the **Corner type** drop-down list, select *Corner finish*.
  - From the **Corner finish** drop-down list, select *straight*.
  - Define the corner size: **10**.

![Figure 226: Properties dialog box – Gusset plate contour tab](image)

- **On the Gusset plate parameter tab:**
  - For the **Projection 2** parameter enter **50** to modify the gusset plate shape at sandwich plates.

![Figure 227: Properties dialog box – Gusset plate parameter tab](image)

- **On the Tab plate tab:**
  - Define a cut back length of **50** from the last bolt.

![Figure 228: Properties dialog box – Tab plate tab](image)
Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.

For a more realistic presentation of the model, use the **Realistic** visual style.

Figure 229: The joint at B3-B4 – in shade mode

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.
Step 13: Creating a tube connection with sandwich plates for a beam as an additional object

In this step, create a tube connection with sandwich plate to connect the **B3 – B4** beam with the **B4** column and the bracing.

1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click .
2. From the **Tube joints** category, click .
3. Select the **B4** column and press **Enter**.
4. Select the **B4 – B3** rafter and press **Enter**.
5. Select the bracing and press **Enter**.
In the properties dialog box, select the General category and define the following settings:

- **On the Gusset plate parameter tab:**
  - Define the gusset plate thickness: 10.

- **On the Gusset plate contour tab:**
  - From the Corner type drop-down list, select Corner finish.
  - From the Corner finish drop-down list, select straight.
  - Define the corner size: 10.

- **On the Bolts in gusset plate tab** set the number of bolts:
  - Define a cut back value of 200 from the column.

- **On the Tab plate tab:**
  - Define a back length of 50 from the last bolt.
For a more realistic presentation of the model, use the **Realistic** visual style.

![Realistic visual style](image)

Figure 236: The joint at B4 column in shade mode

To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

![Visual styles panel](image)

**Step 14: Creating a tube connection middle with sandwich plates**

In this step, connect the bracings between the B3 and B4 columns by a tube connection middle with sandwich plates.

![Joint location in the model](image)

Figure 237: Joint location in the model
1. Open the Connection vault: On the **Home** tab, **Extended modeling** panel, click ![Connection vault](image)

2. From the **Tube joints** category, click ![Tube joints](image)

3. Select the continuous diagonal and press **Enter**.

4. Select one of the two split bracings and press **Enter**.

5. Select the other split bracing and press **Enter**.

6. Click **OK** in the “Attention” dialog box.

The joint is created and the properties dialog box appears.
Modifying the tube connection properties

In the properties dialog box, define the following settings:

- On the **Gusset plate basic** tab:
  - Define the thickness of the gusset plate: 10.

![Properties dialog box – Gusset plate basic tab](image)

- On the **Gusset plate parameter** tab, from the “Shape” drop-down list, select **2 corners**.

![Properties dialog box – Gusset plate parameter tab](image)

*For a more realistic presentation of the model, use the Realistic visual style.*

---

**Note:** For a clear view, display the bolts in the solid representation.
To cancel the shading, click the **2D Wireframe** option on the **Visual styles** panel.

Figure 243: The model with all connections
Lesson 8: Collision check

With Advance Steel you can check for collisions in beams, plates, and bolts for either the entire model or a selection set.

The tool compensates for geometric inaccuracies with a given minimum volume of the collision solids set in the defaults. ACIS-solids are considered in the collision and collisions with a small volume are ignored.

In this lesson, you will learn how to:

- Check for collisions
- Display checking results
- Mark collision objects
- Repair collisions

Step 1: Checking for collisions

Once the model is finished, check it for collisions.

1. On the Home tab, Utilities panel, click

![Utilities](image)

The collisions are listed in the text window with continuous index numbers.

2. Press F2 to see the list of collisions in the text window.

There are 4 collisions in the model:

- Two between the joist diagonal bars and the rafters
- Two at the moment end plate connections

![List of collisions](image)

**Figure 244: Text window – List of collisions**

**Note:** Collision solids are not created.
Step 2: Displaying a collision
For each collision, the collision solid can be displayed.

1. On the **Home** tab, **Utilities** panel, click \(\text{\textbullet} \) to display a certain collision.

2. On the command line, enter the index number of a particular collision, for example 3 (the collision between the rafter and the joist diagonal bar).

   ![Command Line](image)

   **Figure 245: Collision index number on the command line**

   The collision solid is created and displayed in red.

   In complex models, collision solids are hard to find. The “Search highlighted objects” tool creates a red arrow that shows the location of the collision solids.

3. On the **Selection** tool palette, click \(\text{\textbullet} \) to display the arrow pointing to the collision.

   ![Locating Collision](image)

   **Figure 246: Locating the collision**

**Unmarking collisions**

On the **Standard** tool palette, click \(\times \) to unmark the found collisions.
Step 3: Repairing the collisions
In this step, repair the collisions found at the joist and the moment end plate connections of the C6 and D6 columns.

Collision number 4 and 3
This collision appears between the joist diagonal bars and the B2 – B3 and F3 – F3 rafters.

Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.

To repair the collision, modify the Opening P distance.
1. Select a joist element.
2. Right click and select Advance Joint Properties from the context menu.
3. In the properties dialog box, on the Geometry tab, in the Opening P field, enter 360.

Both collisions are repaired.

Collision number 1 and 2
This collision appears between the lower bolts of the moment end plate connections and the E1 – C1 curved beam.

1. On the Home tab, Utilities panel, click to display a certain collision.

2. On the command line, enter 1.
The collision solid is created.
3. On the Selection tool palette, click to display the arrow pointing to the collision.

![Figure 248: Locating the collision](image)

To repair the collision, modify the distance between the bolts.

4. Select an element of the moment end plate connection, for example, the plate.

5. Right click and select Advance Joint Properties from the context menu.

6. In the properties dialog box, on the Vertical bolts tab, enter 70 in the Intermediate distance field.

![Figure 249: Properties dialog box – Vertical bolts tab](image)

As Collision 2 is similar, use the same procedure to modify the joint properties of the moment end plate joint connecting the E1 column with the curved beam.

Recheck the model using the “Clash check” tool to make sure there is no additional collision found.

```
<table>
<thead>
<tr>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>No collisions found</td>
</tr>
<tr>
<td>---------------------</td>
</tr>
</tbody>
</table>
```
Lesson 9: Displaying connected objects

In this lesson, you will learn to:

- Display objects connected in workshop
- Display connected Advance objects
- Check the objects in relation to their connecting elements

Step 1: Displaying objects connected in shop

The “Display objects connected in shop” tool, displays the objects connected in the workshop, including beams, plates, bolt patterns and welds.

In this step, display objects connected in the workshop to the A6 column.

Use the buttons on the Viewpoints panel to change the view angle.

1. On the Selection tool palette, click .

**Note:** To remove previous marking and simultaneously display objects connected in the shop, on the Selection tool palette, click .

2. Select the A6 column and press Enter.

The objects connected in the workshop are highlighted in red.

3. On the Selection tool palette, click to select the marked objects (column, clip angles and base plate).
Use the Real-Time Sphere to rotate the drawing in 3D and get a suitable position.

Step 2: Displaying connected objects
The “Display connected objects” tool highlights the objects with both workshop and site connections, including beams, plates, bolt patterns and welds. This tool is useful to check if the elements of a model are connected.

Displaying all connected objects

1. On the Selection tool palette, click .
2. Select an element from the model, for example, the A6 column and press Enter.

The connected objects are highlighted in red.

Notice that the joist is not highlighted, as it is not connected to the rafters. To fix this, the plates must be welded to the rafter.
Creating the necessary connection

1. On the Home tab, Objects panel, click .

2. Select the elements to connect: the rafter and the joist seat and press Enter.

3. Click the weld point.
   The weld is created.
   Using the same process, create another weld between the other plate and the rafter.

Redisplaying all connected objects

1. On the Selection tool palette, click to remove the marking.

2. On the Selection tool palette, click again .
   The complete model is highlighted in red, provided that all connections were applied correctly.

Note: To remove previous markings and to simultaneously display connected objects, on the Selection tool palette, click .
Step 3: Displaying connection means

The “Display connection means” tool, checks the objects in relation to their connecting elements and identifies them. For example, it can determine if weld points are placed far away from the objects to be welded.

In this step, display the connection means for the A6 column.

1. On the Selection tool palette, click 

Note: To remove previous marking and to simultaneously display connection means, on the Selection tool palette, click.

2. Select the A6 column and press Enter.

The connected objects are highlighted in red and their number is displayed on the command line.

Figure 254: A6 column

Figure 255: Command line
The highlighted objects can be pointed with arrows using the tool “Search marked objects”.

Figure 256: Locating connection elements in the model

3. On the Selection tool palette, click X.

The marking is removed.
Lesson 10: Creating cameras

In this lesson, you will learn how to:

- Create a camera
- Modify camera properties
- Modify the position of an elevation view

Concept
The camera is an object representing the location, angle, and depth of a view, allowing individual focus for automated detail drawing creation. The camera's model views, elevations or overview settings and node details can be presented, named, and saved.

Before starting

Use the buttons on the Viewpoints panel to change the view angle.

Step 1: Inserting a camera according to the UCS

Insert a camera and get an elevation detail for the rear of the structure. The camera is created using the current user coordinate system. The view direction runs against the Z-axis.

For the first camera, use the lower end of the G6 column.

Place the UCS in a suitable position as in the Figure 258. The XY plane is in the elevation plane.

1. On the UCS tool palette, click  
2. Specify the new origin point in the lower system line end point of the G6 column.
3. Next, rotate the UCS so that it is placed as in the Figure 258.

4. On the Tools tool palette, click to create a camera according to the current user coordinate system.

5. On the command line, enter the origin of the camera: 0,0,0.

   The camera is created and the properties dialog box appears.

6. In the camera properties dialog box, make the following settings:
   
   On the Properties tab:
   
   − From the Type drop-down list, select Overview.

   Figure 259: Camera properties dialog box – Selecting the camera type

   − In the Description area enter Elevation View 1.

   Figure 260: Camera properties dialog box – Adding a description
On the **Detail box** tab define the camera size so that all necessary elements are included:

- Select the **Front** and **Rear** options and enter the Z values to define the clipping distance in front and behind the grid on the UCS plane (depth).
- Select the XY Viewport: **Fixed**.
- Define the elevation length (in the X direction): **12000**.
- Define the elevation height (in the Y direction): **6000**.

![Figure 261: Camera properties dialog box – Setting the detail box size](image)

The grid is stretched around the origin. The pencil-top shows the view direction against the positive Z-axis.

On the **Display type** tab, select the **Standard** option.

![Figure 262: Camera properties dialog box – Display type tab](image)

*Use the buttons on the **Viewpoints** panel to change the view angle.*

![Figure 264: Camera – Front view](image)
Step 2: Moving the camera

1. Select a grip point of the camera.

2. Right click and select Move from the context menu.

Use the buttons on the Viewpoints panel to change the view angle.

To create a second camera at the lower system line end point of the G3 column, place first the UCS in a suitable position as in the Figure 267. The XY plane is in the elevation plane.
Next, move the UCS with the origin in the lower system line end point of the G3 column. Using the same process, create an overview camera with the origin in the origin of the new coordinate system.

1. On the **UCS** tool palette, click ![UCS Icon](image)
2. Specify the new origin point in the lower system line end point of the G3 column.
3. Next, rotate the UCS by Y to place the coordinate system in a suitable position (see Figure 272).

![UCS Tool Palette](image)

4. On the **Tools** tool palette, click ![Tools Icon](image) to create a camera according to the current user coordinate system.
5. On the command line, enter the origin for the camera: 0,0,0. The camera is created and the properties dialog box appears. In the camera properties dialog box, make the following settings:
   - On the **Properties** tab:
     - Select the type of the camera: **Overview**.
     - In the **Description** area enter **Elevation View 2**.
   - On the **Detail box** tab define the camera size so that the necessary elements are included:
     - Select the Front and Rear options; the Z values refer to the clipping distance in front and behind the grid on the UCS plane (depth).
     - Select the XY Viewport: **Fixed**.
     - Define the elevation length: 16000.
     - Define the elevation height: 6000.
The grid is stretched around the origin. The pencil-top shows the view direction against the positive Z-axis.

- On the **Representation type** tab, select the **Standard** option.

---

**Use the buttons on the Viewpoints panel to change the view angle.**
Use the Move tool to move the second camera:

1. Select a grip point of the camera.

2. Right click and select **Move** from the context menu.

   ![Figure 274: Moving the camera](image)

   ![Figure 275: Moving the camera – new position](image)

   *Figure 274: Moving the camera*

   *Figure 275: Moving the camera – new position*

*Use the buttons on the Viewpoints panel to change the view angle.*

![Figure 276: The model and the two cameras in 3D view](image)

*Figure 276: The model and the two cameras in 3D view*
Step 3: Changing the camera color

In this step, change the color of a camera to distinguish it from the other one.

1. Select the second camera.
2. On the Utilities tab, Properties panel, from the first drop-down list, select Cyan.

Figure 277: Selecting the new camera color

The camera is reassigned to another color.

The cameras created in this lesson are used for the drawing creation, in Lesson 12: Drawings.

To turn the camera representation off, hide the Cameras Layer.

Figure 278: The model
Lesson 11: Numbering

In this lesson you will learn how to:

- Configure automatic prefixes for single part and assembly numbering
- Number the elements

Concept

The **Advance numbering** tool automatically numbers **Single Parts** and **Assemblies** for the entire model. The basis for the numbering is finding **identical parts** that should have the same mark.

The elements are compared by geometry, material properties, coating, and commodity (and behavior). The properties name and lot/phase are not considered for numbering. The model role is used by the automatic prefix tool to assign prefixes but not used directly for numbering.

If nothing is selected, the entire model is numbered. When Advance objects are selected, only these items are numbered. The results in either case are recorded in the text window (or by a default setting, they can be recorded in a text file that can be saved).

*Use the buttons on the Viewpoints panel to change the view angle.*

![Figure 279: The gusset plate location in the model](image-url)
Step 1: Setting prefixes
In this step, configure the automatic prefixes used for single part and assembly numbering. The prefix is based on the model role.

1. On the **Output** tab, **Part marks** panel, click ![Part marks icon]

   ![Part marks panel](image)

   In the “Prefix configuration” dialog box set different profiles for different jobs.

2. Select the **Use prefix** option to activate the prefix settings.

   **Note:** The **User** tree includes a copy of all the prefix profiles from the Advance tree and can be modified.

3. Expand the **User** branch and select Default\Plates\Any\Gusset Plate to define the prefixes for gusset plates.

4. In the right side of the window enter the prefixes for single parts and assemblies.

![Setting the prefixes for the gusset plates](image)

   Figure 280: Setting the prefixes for the gusset plates

5. Right click **Default** and select **Set as current profile** from the context menu.

![Setting the current profile](image)

   Figure 281: Setting the current profile

6. Click **OK**.
Step 2: Numbering

Once the prefixes are set, perform the numbering process for single parts and assembly parts in one step. The biggest part of an assembly is the main part and will get an assembly number; all the other parts are considered attached and will have single part numbers.

1. On the Output tab, Part marks panel, click 

2. In the “Numbering” dialog box, define the following settings:
   - On the General tab, select the Process single parts and Process assemblies options to number the single parts and assemblies in one step.

![Numbering dialog box](image)

**Note:** The numbering for single parts and assembly parts can be performed separately. In this case, the single part numbering must be done first.

3. Click OK.

The results appear in the command line. To display the text window, press F2.
Step 3: Displaying the results

For each element of the model the part marks are displayed in the properties dialog box.

1. Select the middle gusset plate between the G4 and G5 columns.
2. Right click and select **Advance Properties** from the context menu.

The single part and assembly numbers are shown with their prefixes.

![Figure 283: Properties dialog box – single part and assembly numbers](image)

Figure 283: Properties dialog box – single part and assembly numbers
Lesson 12: Drawings

After building the 3D model, you can automatic create dimensioned and labeled 2D general arrangement and shop drawings. The linked drawings are created in separate DWG files from the model, but they are linked to track changes.

In this lesson, you learn how to:

- Create automatic detailing of all the single parts in the model using processes
- Modify the scale of a detail
- Insert a label in the linked drawings using the model information
- Insert a linear vertical dimension
- Create automatic detailing of all the main parts in the model using processes
- Insert a weld symbol
- Insert a structured list in a drawing

Concepts

**Drawings**: A drawing may consist of several linked details, which are individual Advance objects having their own properties. The model knows which drawings have been linked and checks if these drawings still correlate. Thus, the drawings can be updated after any model modifications. This link is 'one way' and changing a drawing cannot modify the model.

**Processes**: In addition to drawing styles, Advance has Processes, which automatically create drawings (using appropriate drawing styles) and arrange the linked details within the drawing (DWG) or across several drawings.

A process includes a number of sub-processes: selection of parts, sorting, drawing style selection, rules for arranging details on the sheet, and rules to attach new sheets.

Before starting

If necessary, change the color of the visible lines in the GRAITEC Advance Manager - the configuration tool used by Advance to modify default information for modeling, drawing creation, database management as well as many other management settings.

1. From the Windows start menu: All Programs > Graitec > Advance Manager 2013 > Advance Manager 2013
2. From the Settings category, select Defaults.
3. On the “Defaults” tab, AdvanceSteel category, from the Drawing-presentation category, Color group, select Color of visible lines to modify the default color of the visible lines.
4. In the right side of the window select the desired color.

Figure 284: Defining the default color of the visible lines in details
Step 1: Automatic detailing of all the single parts in the model
Using processes, create drawings for all the single parts in the model.

1. On the **Home** tab, **Document creation** panel, click ![Quick documents](image).
2. In the Quick documents window, select **All Sp PageFull A0**.

![Figure 285: Selecting the process](image)

3. Click **Use**.
4. In the process properties dialog box, from the **Selection** drop-down list, select **All Sp**.

![Figure 286: Process properties dialog box](image)

A new folder is created with the same name and at the same location as the DWG model. The linked details are saved in .dwg files in the **Details** sub-folder.

5. To see the details, from the Quick start toolbar, click **Open**.
6. In the Details folder, open the desired .dwg file, for example, the 001_A0-Detail.dwg file.

![Figure 287: The 001_A0-Detail file](image)

**Warning!** If a DWG model or a DWG drawing is renamed, the relationship is broken, but can be recreated (registered). Drawings can also be separated (unlinked) from the model.

---

**Step 2: Modifying the properties of a detail**

Next, modify the scale, and manually add a label and a dimension.

**Modifying the scale of a detail**

1. Select the green frame of a detail, e.g., a detail of a beam.

![Figure 288: Selecting the detail frame](image)

2. Right click and select **Advance Detail Properties** from the context menu.
3. In the details properties dialog box, from the **Scale** drop-down list, select **1:20**.
4. Click **OK**.

**Inserting a label**

In Advance, the 3D model and the associated drawings are linked to each other; therefore, it is possible to create additional labels in the linked drawings using the model information.

1. On the **Labels & Dimensions** tab, **Parametric labels** panel, click ![Insert label](image).
2. Select the detail on which to add a label.
3. Select the label start point.

4. Select the text start point.

5. Define the text angle using the mouse pointer.

6. Press Enter to finish.

The label is placed.

**Inserting a linear vertical dimension**

Insert a linear vertical dimension on the same detail.

1. On the Labels & Dimensions tab, Parametric dimensions panel, click  

2. Select the detail on which to add a label.

3. Select the first dimension point.

4. Select the second dimension point.
5. Select a point to define the dimension line position.
6. Press **Enter** to finish.
   The linear vertical dimension is created.
7. Press **Esc** to close the command.
   Close the dimension properties dialog box.

---

**Step 3: Automatic detailing of all the main parts in the model**

Using a process, create automatic drawings for all the main parts in the model.

Go back to the model DWG.

1. On the **Home** tab, **Document creation** panel, click ![Quick documents](image)
2. In the Quick documents window, select **All Assembly Beam PageFull A0**.

   ![Quick documents](image)

3. Click **Use**.
4. In the process properties dialog box, set the drawing number options for the drawings created by the process: the first number and the increment number.
5. From the **Selection** drop-down list, select the **All Mp** option.
6. Click **OK**. The linked details are created in the **Details** folder.

7. To see the details, from the Quick start toolbar, click **Open**.

8. From the **Details** folder, open the desired .dwg file, for example, the **003_A0-Beam** .dwg file.

![Figure 290: Process properties dialog box](image)

**Inserting a weld symbol**

In Advance, the 3D model and the associated drawings are linked to each other; therefore, it is possible to create additional weld symbols in the linked drawings using the model information.

1. On the **Labels & Dimensions** tab, **Parametric labels** panel, click **Insert weld symbol**.

2. Select the detail on which to add the weld symbol. For example, select the detail of a beam.

3. Define the symbol reference point on the detail.
4. Define the symbol position point.

The weld symbol is created.

5. In the weld symbol properties dialog box, define the following settings:
   - On the **Upper weld** tab, define the weld thickness: 10.
   - On the **Lower weld** tab, from the **Weld type** drop-down list, make sure to select the **None** option.
   - On the **Weld definition** tab, from the **Location** drop-down list, make sure to select the **Shop** option.
Step 4: Inserting a structured list in a drawing
Next, insert a structured list in the detail drawing.

1. On the Labels & Dimensions tab, Management panel, click "Insert a list".

2. Select a point for the upper right point of the list frame.
3. Select the second point for the lower left point of the list frame.
4. In the list properties dialog box, make the following settings:
   - On the Layout tab, do not define fixed points to specify a specific width and height of the list.
   - Note: This way, the list is not limited from extending as more material is added.
   - On the Templates tab, from the Advance Templates group, select the Drawing – Structured list layout.
5. Close the dialog box.

The structured list template is added on the drawing. The list must be updated using the information from the model.

1. On the Labels & Dimensions tab, Management panel, click "Update lists" to update the list.

The structured list is automatically updated.
Lesson 13: Generating details using cameras

In this lesson you will learn how to:

- Insert level symbols in the model
- Create details generated by automatic detailing processes using cameras
- Modify level symbols properties in drawings
- Insert level symbols in drawings

Step 1: Inserting a level symbol in the model

In this step, create a level symbol on top of the base plate of the G6 column.

1. On the Home tab, Objects panel, click .

2. Select the insertion point on top of the base plate from the G6 base plate joint, as in Figure 300.

Figure 299: The G6 column

Figure 300: Level symbol insertion point
3. In the level symbol properties dialog box, on the **Default** tab, define the symbol size: **200**.

![Figure 301: Properties dialog box - Defining the symbol size](image)

**Note:** On the **Current** tab, notice the height notations in reference to a zero level (absolute) and to the WCS (relative): **20**.

![Figure 302: Properties dialog box – Current tab](image)

The level symbol is created.

![Figure 303: The level symbol](image)

Using the same process, create level symbols on top of the **G5-G6** middle beam and on top of the **G6** column.

![Figure 304: Level symbol properties](image)
Step 2: Creating details using cameras

The cameras can be used in processes for automatic creation of details.

In this step, create detail drawings from the cameras created in Lesson 10: Create cameras.

Before starting

Turn on the Cameras layer to display the cameras.

1. On the Home tab, Document creation panel, click [Click to display].
2. In the Quick documents window, select All Cameras PageFull A0.
3. Click Use.
4. In the process properties dialog box, from the Selection drop-down list, select All Cameras.

Figure 305: The model and the created cameras

Figure 306: Process properties dialog box
5. Click **OK**.
The linked details are created in the **Details** folder.

6. To see the details, from the Quick start toolbar, click **Open**.

7. From the **Details** folder, open the 008_A0-Camera.dwg file.

![Figure 307: Selecting the dwg to display](image)

**Note:** Notice that the level symbols are represented in the drawing!

![Figure 308: Level symbols](image)

**Modifying level symbol representations**
You can modify the representation of the level symbols directly on the drawing.

1. Select a level symbol.
2. Right click and select **Advance Properties** from the context menu.
3. In the properties dialog box, on the **Presentation mode for Level Symbols** tab, make the following settings:
   - From the **Unit** drop-down list, select **Millimeter** to display the height in millimeters.
   - From the **Precision** drop-down list, select **0.000**.

The value in the level symbol is displayed with $10^{-3}$ precision and is converted to millimeters.
Step 3: Inserting a level symbol in the drawing

In Advance, the 3D model and the associated drawings are linked to each other; therefore, it is possible to create additional level symbols in the linked drawings using the model information.

Next, insert a level symbol in the drawing.

1. On the Labels & Dimensions tab, Parametric labels panel, click [Insert level symbol].

2. Select the detail on which to add a level symbol.
   For example, select the detail shown in the Figure 310.

3. Define the symbol reference point at the detail.

4. Define the symbol position point.
   The level symbol is created.
Lesson 14: Exploding details

In this lesson you will learn how to:

- Explode a detail
- Batch explode for all selected drawings

After exploding the details, the elements of the details are seen as individual Advance components and can be adjusted separately.

**Before starting**

Go back to the model DWG and turn off the **Cameras** layer.

**Step 1: Adding to explode details**

To explode the details, open the **Document Manager** from the **Document creation** panel.

The **Document Manager** manages and presents the connection between the model and the linked drawings: you can display, update, add a revision, flag the issue of drawings, add to batch plot or batch explode, and delete the drawing details.

In this step, add to explode the drawing details.

1. On the **Home** tab, **Document creation** panel, click **Document Manager**.

   **Note:** The **Document Manager** checks automatically if drawings require an update due to model modifications or you can select the drawings to be checked. Drawing updates are done directly from the **Document Manager**.

   The “Document Manager” window appears.

2. From the **Project documents** tree, **Details** group, select the **Current** sub-group.
3. Click **Add to explode**.
The drawings are copied to a new category named **Batch Explode**.

4. Select the **Batch explode** tree.

5. On the **Properties** tab, click ![Properties Tab](image)

   The “Detail Explode” window appears.

6. Select the **Enable Detail Explode** option to activate the detail explode settings.

7. Select the **Advance** profile as the current profile.

   **Note:** In the **Advance** profile, expand the **Beam** group and select **Label**. Notice that the detail explode settings cannot be modified.

8. Click **OK** in the “Detail Explode” window.

9. Click **OK** in the “Document Manager” window.

10. Click **OK** in the “Documents to print or delete or explode” dialog box.

   ![Confirming detail explode](image)
The details are exploded.

A new folder named **DetailsExploded** is created at the same location as the **Details** folder. The linked exploded details appear in different .dwg files in the **DetailsExploded** folder.

11. To open the exploded details, from the Quick start toolbar, click **Open**.

12. From the **DetailsExploded** folder, select the .dwg file, for example **001_A0-Detail.dwg**.

![Figure 314: Selecting the dwg file](image)

The elements of a detail are now simple entities and can be adjusted separately.

![Figure 315: Exploded detail](image)
Lesson 15: Creating external lists

All model objects including their graphic and non-graphic properties, features, joints and connections are stored and managed by Advance. Extracts are created from the numbered and saved models. The Advance List Template Wizard creates structured BOMs (Bills of materials) from the extracts. The created BOMs can be saved, printed, or exported in various formats.

In this lesson you will learn how to:

• Create a model extract
• Create a list
• Export a list

Step 1: Creating a model extract

In this step, a model extract is created based on the model information. Later on, the Advance List Template Wizard creates structured BOMs from the extracts.

1. On the Home tab, Document creation panel, click .

3. In the “Selection of model objects for the list” dialog box, select the Complete Model option to use the complete model for the list.

4. Click Apply.
5. Click Next.
6. In the “Select destination file” dialog box, click Create lists to start creating and printing the information list.
Step 2: Creating a list
In this step, create a list based on the model extract.

1. From the Advance Template tree, Lists group, Part List sub-group, select the Material list template.
2. Click Use.

   Figure 318: Template editor

3. In the “Select the model extract for the BOM” dialog box, select the desired .xml file.

   Figure 319: Selecting the model extract

4. Click OK.

The list containing all the elements of the model appears in a new window.

   Figure 320: The list
Step 3: Exporting a list

In this step, export a list to PDF format.

1. On the Material list toolbar, click Export.
2. In the “Report export” dialog box, from the Export Format drop-down list, select Portable Document Format (PDF).

![Figure 321: Exporting the list to pdf](image)

3. Click OK.
4. In the “Save as” dialog box, enter the name of the created BOM file: MaterialList.

![Figure 322: Naming the pdf file](image)

5. Click Save.
   The list is saved in PDF format.

**Note:** The file is saved by default in the BOM folder corresponding to the model DWG.

6. Close the BOM Editor.
7. In the “Preview selected template” dialog box, click Yes.
8. In the “Save as” dialog box, enter the name of the report: MaterialList.
9. Click Save.
   The report is saved in RDF format.

**Note:** The file is saved by default in the BOM folder corresponding to the model DWG.

10. In the “Template Editor” window, click OK.
    The list is exported in PDF format.