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INTRODUCTION
This starting guide is a brief introduction to working with Advance CAD,
describing the basic methodology and not meant to replace formal training.
The first two chapters of this guide describe the steps involved in installing
the software and a short description of Advance CAD’s user interface. In
the following chapters, the most simple Advance CAD entities, some
working methods and dimensioning tools are presented using simple
examples as steps in the creation of the floor plan of a small building.
The examples presented in this guide are generic for worldwide use and do
not conform to local or specific company standards.
Since not all Advance CAD tools are described in this guide, refer to the
Help for more details on all commands and parameters.

About Advance CAD
Advance CAD is a CAD software that works under the Windows operating
system. It provides a simple user-friendly working environment for creating
2D drawings. A large selection of drawing and dimensioning tools allow the
creation of simple as well complex drawings.
Advance CAD uses the native .dwg file format.

Where to find information
Using the help
Advance CAD has a help system that offers step-by-step instructions for
every function.
To access the help:
•

Help tab, Help panel: click
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INSTALLATION
To successfully install Advance CAD certain requirements must be met.

System requirements
For more details, see the Installation guide on the Documentation CD or
www.graitec.com/en/advance_installation.asp.

Starting the installation
Close all active Windows applications before starting the installation.
Proceed with the installation as follows:
1. Insert the installation DVD in the DVD drive.
2. Start the installation by following one of these procedures:
–

On the DVD – Browser, click SetupAdvance.

–
–

.
On the Windows task bar, click
In the Search programs and files field, enter SetupAdvance.exe.
Double-click the file to start.

or

3. Select the installation language and click Install the products.
4. To install only Advance CAD, select Custom setup then select
GRAITEC Advance CAD.
5. Click Next.
6. Read the license agreement, select I agree and click Next.
7. On the next screen, select the interface language and the installation path.
–

To select the interface language, click Customize. In the next
dialog box, select the interface language and the local settings for
each installed application and click <OK>.

–

To change the destination path, click
. In the next dialog box,
enter a path or select a different folder in which to install Advance
and click <OK>.
8. Click Install to start the installation.
The installation process starts.
9. Once the installation process is complete, click Exit.
After installing Advance CAD, a license is required to use the software. To
authorize the software, follow the procedure described in the “Installation
guide” or contact the reseller.
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STARTING ADVANCE CAD
To start Advance CAD:
–

Double click the Advance CAD icon on the desktop.

–

On the Windows task bar, click

or
, then select

All programs > Graitec > Advance CAD > Advance CAD.
Advance CAD startup page appears.

ADVANCE CAD USER INTERFACE
Once the program has started, the following window appears:

1. Menu Browser button
All the commands and tools are accessed using the Menu Browser.
The button in the upper left corner displays the Menu Browser.
2. Quick Access Toolbar
The Quick Access Toolbar groups the frequently used commands:
New, Open, Save, Undo, Redo, etc. More commands can be added
using the Quick Access Toolbar context menu.
3. Ribbon
The ribbon consists of several tabs. Each tab contains panels and
each panel contains commands and buttons. Some of the buttons
open flyouts. The flyout buttons are identified with a black triangle on
the lower right corner. The contained commands appear when the
button is held down.
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4. Tool palettes
For easier access, the most used editing tools are grouped on the tool
palette.
5. Drawing area
The drawings are displayed in the drawing area.
6. Command line
On the command line, commands can be entered using the keyboard.
Press Enter after each entry.
7. Status bar
If the command line is not used, the status bar displays information
about the selected command or tool. It also displays the current cursor
coordinates, the name of the current layer, mode settings and other
information about the current settings.

Some useful tools
•

To cancel a command in Advance CAD, press the Esc key.

•

To repeat a command, press Enter.

•

The current command and prompts are displayed on the command line
window at the bottom of the screen. Press the F2 key to open and
close the command window.

•

When the cursor hovers over a ribbon button, the button’s tooltip
appears.

•

The Undo command on the Advance CAD Quick Access toolbar
cancels one or several commands.

•

The Match properties command on the Advance CAD Utilities panel
copies properties from one object to another. The transferred
properties are selected from the given list.
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WORKING WITH DRAWINGS
New projects are created based on a template file. The template file
contains important defaults like the current coordinate system, the
orientation, object snap settings, layer assignment and color definitions so
that drawing can immediately begin.

Creating a new drawing
To create a new drawing:
1. On the Quick Access Toolbar: click

.

2. Select to display the files of *.dwt type.
3. Select the desired template (*.dwt) file.
4. Click Open.

Saving the drawing
Advance CAD drawings are saved in *.dwg files.
To save the drawing:
1. On the Quick Access Toolbar: click

.

2. Enter the name of the drawing.
3. Click Save.

Drawing settings
Prior to drawing, some specific settings should be made:
•

Layer settings

•

Linear and angular units

Setting layers
Layers are like transparent overlays on which the drawing information is
organized. Drawing entities can be grouped on layers for easier control of
their properties and visibility.
Every drawing has at least one layer. An unlimited number of layers can be
added. Entities are created on the current layer.
The Layer Explorer is used to manage the layers.

9

Advance CAD Starting Guide

Example: Setting layers
In this example, create the layers necessary for a simple drawing: the
floor plan of a small building. For every layer, define its properties (the
name, the color and the line type).
1. On the Home tab, on the Layers panel, click
2. In the Layer Explorer click

.

.

A new layer is created.
3. Next, modify the layer properties:
–

Enter Axes for the layer name.

–

In the “Color” column, click the rectangle and select another

–

In the “Linetype” column, select CenterX2.

color from the color palette (e.g.

Note:

).

If the desired linetype is not available in the list, it must be
loaded.




Click in the “Linetype” column.



Select CenterX2 and click OK. CenterX2 is displayed in
the Linetype manager.

In the Linetype manager, click Load to access the list of
additional linetypes.

Using the same process, create new layers and modify the colors and
the line type as in the following figure.
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To define a layer as current, double-click it in the “Layer Explorer”, or on
the Layers panel, select it from the drop-down list.

Setting units
With Advance CAD, by default, drawings are created at 1:1 scale.
Before starting, the relationship between the drawing units and the realworld units must be defined. A linear drawing unit may represent an inch, a
foot, a meter or a mile.
The precision must also be set. The precision settings affect only the
display of distances, angles and coordinates.
Example: Setting the project working units
For the small project described in this guide, the input values are in
meters, with two decimal places.
1. On the Manage tab, on the Settings panel, click
“Units” dialog box appears.

. The

2. Define the following settings for the length units:
– Select the Decimal format.
– In the “Precision” field select
0.00 to display only two
decimal places.
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2D DRAWING
Advance CAD objects are created in 2D space using the appropriate tools.

Drawing geometric entities
Advance CAD can create all geometric entities: finite and infinite lines,
circles, arcs, ellipses, elliptical arcs, points, etc. A freehand tool is used to
create irregular boundaries.
Advance CAD can also create complex entities: polylines, rectangles,
spline curves, donuts and planes.
When using a tool, the software prompts for point coordinates, arcs or
distances. The following can be done:
• Define coordinates: enter the point coordinates on the command line.
• Use entity snaps: select exact geometric points on existing entities
without knowing the exact the coordinates of these points.
– To enable entity snaps, on the status bar, rightclick OSNAP and select On.
– To set the entity snaps, on the status bar, rightclick OSNAP and select Settings.
In the “Drafting settings” dialog box, the Object snaps tab is used to select
the OSNAP modes.

There are several ways to create an entity. Not all entities and not all
creation methods are presented in this guide.
Before drawing the elements, define the current layer.

Drawing lines
Finite and infinite lines can be drawn:
•
•
•
12

Line – creates a simple line with connected segments, each segment
is a separate line object.
Ray – creates a semi-infinite line.
Infinite line – creates an infinite line.
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Example 1: Drawing semi-infinite lines by a start point and direction
In this example, create a grid consisting of axes in the X and Y
directions, which is used in the next chapters of this guide.
Before starting, activate the Axes layer.
1. On the Home tab, on the Draw panel,
select

from the flyout.

2. Press F8 to activate the ORTHO mode.
3. On the command line, enter 0,0,0 to
define the start point in the origin.
4. Move the mouse pointer in the X
direction and click a point.
5. Press Enter to finish.
Using the same process, draw another ray from the origin, in the Y
direction.
Next, create the horizontal axes, parallel with X, using the following
coordinates as start points.
Tip:

Press Enter to repeat the last executed command – in this
case, "Ray".
0, 3.16, 0
0, 5.32, 0
0, 7.32, 0
0,10.64, 0

Using the same process, create vertical axes, parallel with Y, using as start
points the following coordinates:
5.32, 0, 0
8.48, 0, 0
10.64, 0, 0
13.30, 0, 0
15.96, 0, 0
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Example 2: Drawing contiguous lines
In this example, create the wall contour as in the picture below using
the axis intersection as start and end points.
Before starting, activate the Wall contours layer.
Make sure that OSNAP is active and end point and intersection are set.
1. On the Home tab, on the Draw panel, select
flyout.
2. Specify the first point of the line.
3. Specify the second point of the line.
4. Specify segment end points as needed
to get the contour as in the figure.
5. Press Enter to finish.
Example 3: Creating a line by two points
1. On the Home tab, on the Draw panel,
select

from the flyout.

2. Specify the first point of the line.
3. Specify the second point of the line.
4. Press Enter to finish.
Using the same process, draw all necessary
lines as in the figure.
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As you draw, you may need to frequently change the magnification and the
view position in the drawing area. These tools are grouped on a flyout of
the View panel of the View tab.

Drawing arcs
Arcs are drawn clockwise from the start to the end point. There are several
methods to create an arc:
•

By 3 arc points

•

By start, center and end point

•

By center, start point and angle

•

By center, start point and length

All tools are grouped in a flyout accessible on the Draw panel of the Home
tab.

It is also possible to create an arc by trimming a circle. In practice, arcs are
often created this way.
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Example: Drawing an arc by a start point, center and end point
Next, create the contour of the circular wall.
1. On the Home tab, on the Draw panel, click

.

2. Specify the start point of the arc.
3. Specify the center of the arc.
4. Specify the end point of the arc.
5. Press Enter to finish.
Draw another line to close the contour.
Now that the wall contour lines are drawn, the Axes layer can be
switched off: in the Layer manager, click in the “On/Off” column to hide
the layer.

Drawing circles
The default method for drawing a circle is to specify the center and the radius.
Other alternative methods are:
–
–
–
–
–

16

Two points defining the diameter
Center and diameter
By 3 points defining the circumference
Circle radius and tangents
Converting an arc to a circle
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Example: Drawing a circle by a center point and radius
Draw the section contour of the spiral stair central post. The column
has a circular section of 0.40 m diameter.
Before starting, draw an additional line on
the Auxiliary layer. The circle center is in
the mid point.
Make sure that OSNAP is active and mid
point and perpendicular are set.

1. Activate the Wall contours layer.
2. On the Home tab, on the Draw panel, select
from the flyout.
3. Click the additional line middle point to define the center of the

circle.
4. On the command line, enter 0.20 for the radius of the circle.
The circle is created. The additional line can be deleted.
Tip:

To delete an entity, select it and press Delete.
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Drawing sketches
The freehand sketch tool is used to draw irregular shapes.
Freehand sketches consist of many line segments. It is necessary to set
the minimum length of the segments. For more accuracy, use small line
segments. Click to put the “pen” down and click again to stop drawing.
Example: Drawing a freehand sketch
To draw freely make sure that the ORTHO mode is off.
1. Activate the Landscape layer.
2. On the Home tab, on the Draw panel, click

.

3. On the command line, enter 0.1 for the minimum length of the segments.
4. Click to put the “pen” down and
draw the sketch line and click
again to stop drawing.
5. Press Enter to quit the command.
The Landscape layer can be hidden.

WORKING METHODS
In practice, it is useful to copy existing entities and modify them. For
example, a line can be offset from an existing line, and adjusted to the desired
length. The grip points or the “trim” and “extend” commands can also be used.
Many editing tools allow moving, rotating or
stretching drawing entities. All editing tools are
grouped on the Modify panel of the Home tab.

Copying entities
One or several entities can be copied within a drawing or between
drawings using any of the following methods:
• Copy at a location referenced from the original
• Copy aligned parallel to the original
• Copy symmetrically to the original
• Create several copies in a rectangular or circular pattern
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Example 1: Creating parallel copies
The walls of the building used as an example have a thickness of 16
cm. Next, create parallel lines at the given distance to get a correct
representation of the walls.
1. On the Home tab, on the Modify panel, click
.
2. On the command line, enter 0.16 for the distance and press Enter.
3. Select the entity to copy, for example, the bottom contour line.

4. Click above the line to place the copy.
5. Select another line to copy, or press Enter to finish.
Create parallel lines as in the figure.

Using the same process copy the arc
also at 16 cm.

Note:

Parallel copies of curved entities are larger or smaller curves,
depending on the side the copy is placed. In this example, a
smaller concentric arc is created.

Example 2: Creating radial copies in a polar pattern
Before starting, draw a line representing the first step of the spiral stair
on the Spiral stair layer.
Make sure that OSNAP is active and center is set.
1. On the Home tab, on the Modify panel, click

.

2. In the “Array” dialog box, select Polar array.
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3. Click

, select the line to copy and press Enter.

5. Click

to select the polar array center.

6. Define the center of the polar array in the center of the circle and
press Enter.
Tip:

For easier selection of the center, type Center on the command line
and press Enter. Next, click the circle to snap to its center.
7. In the “Method and Values” area, make the following settings:
– Enter 18 for the number of entities.
– Enter –270 for the angle to create
radial lines clockwise.
– Select Rotate items as copied to
rotate the entities in the array as
shown in the preview area.

8. Click Preview to view the result.
9. Click OK to confirm. The radial copies of the line are created.

Extending entities
Arcs, lines, 2D polylines and rays can be extended to a boundary defined
by other entities or to the point at which they would intersect an implied
boundary edge.
Example: Extending lines
Extend the lines to close the wall contour. For a clear view, hide the
Spiral stair layer.
1. On the Home tab, on the Modify panel, select
the flyout.
2. Select the vertical line as a boundary line and press Enter.
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3. Select the horizontal line that should be extended.
4. Press Enter to finish.

Trimming entities
Advance CAD allows trimming entities so that they end at boundaries
defined by other entities (lines, rays, polylines, circles, arcs or ellipses).
First select the boundaries, then the entities to trim.
Example 1: Trimming lines
In this example, clean up the intersection of walls. Zoom to the upper
end of the circular wall.
1. On the Home tab, on the Modify panel, click

.

2. Select the boundary lines and press Enter.

3. Select the lines to trim.
Using the same process, clean up all wall intersections as in the figure.
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Example 2: Trimming lines
Display the Spiral stair layer.
1. Zoom to the staircase area.
2. On the Home tab, on the Modify panel, click

.

3. Select the boundary lines and the circle and press Enter.
4. One by one, select the radial lines at both ends.
5. Press Enter to finish.

Chamfering and filleting
Advance CAD allows chamfering and filleting entities. Arcs, circles,
ellipses, lines, polylines, rays or splines can be filleted or chamfered.
A fillet connects two entities with an arc of a given radius. A chamfer
connects two entities by a line.
Example: Creating a fillet
In this example, create a round corner inside the building.
1. On the Home tab, on the Modify panel, select
from the
flyout.
2. On the command line, type R (Radius) to define the fillet radius
and press Enter.
3. Enter 0.84 for the fillet radius and press Enter.
4. Select the inside contour lines of the walls.
The fillet is created.
Using the same process create a fillet for the outside
contour lines of the wall, this time the radius value is 1.
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Drawing other elements
Using the tools discussed in this guide, draw the column contour and the
windows and doors openings.
Before starting, draw all additional lines on the Auxiliary layer as in the
following figure.

to define the openings at the distances given in the
Use Offset tool
following figure. All door openings are 80 cm.
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Example 1: Creating a window opening on the circular wall
In this example, create a window opening on the circular wall. First,
draw two radii at 120° and 150° counter-clockwise.
1. On the Home tab, on the Draw panel, select

from the flyout.

2. Specify the first point of the line in the arc center.
3. On the command line, type A (Angle) to define the
line angle and press Enter.
4. Enter 120 for the angle value and press Enter.
5. Click any point on the outer arc to define the length.
6. Press Enter to finish.
Using the same process, draw the other radius at 150°.
Next, trim the auxiliary lines to create the window
opening.

Example 2: Creating a door opening on the round corner
In this example, create a door opening on the round corner. First, draw
a circle radius at 45° and create copies on both sides.
Make sure that OSNAP center is activated.
1. On the Home tab, on the Draw panel, select

from the flyout.

2. On the command line, type center to snap the arc center, then click.
3. On the command line, type A (Angle) to define the
line angle and press Enter.
4. Enter 225 for the angle value and press Enter.
5. Click any point on the outer arc to define the length.
6. Press Enter to finish.
7. Use the Offset tool
to create copies of the line on both sides,
at 40 cm.
8. Delete the original line.
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Next, trim the wall contour to create the door opening.
1. On the Home tab, on the Modify panel, click

.

2. Select the auxiliary lines and press Enter.
3. Click the wall contour lines between the auxiliary lines.
The door opening is created. Use the trimming tool to adjust the two
auxiliary lines.

Next, trim the wall contours to create all the necessary door openings.

Modifying entities properties
After creating entities their properties can be modified using entity
modification tools. The layer, thickness, line type, color and line type scale
of one or several entities can be changed.
Example: Changing the layer
In this example, move the openings contour lines on the Wall
contours layer.
1. Select the openings contour lines one by one.
2. Right-click and select Properties from the context menu.
3. In the properties dialog box, from the “Layer” drop-down list, select
Wall contours.
4. In the properties dialog box, click OK.
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Now that the wall contours and openings are drawn, hide the Auxiliary
layer.

OTHER TOOLS
Hatches
Hatching means filling entities or the area within a specified boundary with
a selected pattern. The hatch boundary is a closed contour or a
combination of entities such as lines, arcs, circles and polylines.
First select the pattern, then modify the pattern properties and then select
the area.
Example 1: Boundary hatch
Use solid hatch for the circular column. Activate the Hatch1 layer.
1. On the Home tab, on the Draw panel, click
2. In the “Boundary hatch” dialog
box, on the Pattern tab select
the solid hatch pattern.

3. On the Boundary tab, click Select entities.
4. Select the circle and press Enter.
The “Boundary hatch” dialog box appears again.
5. Click OK.

26
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Example 2: Hatching an area
Use solid hatch pattern for the rectangular columns.
1. On the Home tab, on the Draw panel, click

.

2. In the “Boundary hatch” dialog box, on the Pattern tab select the
solid hatch pattern.
3. On the Boundary tab, click Select area.
4. In the drawing, click inside the area to hatch, in this example, inside each
rectangular area defining a column section and press Enter.
The “Boundary hatch” dialog box appears again.
5. Click OK.

Using the same process, hatch the walls using an ANSI38 hatch
pattern, at 0.4 scale. Create this hatch on the Hatch2 layer.

Blocks
Several entities can be grouped into a single entity – “block” – and then
reused in multiple drawings as many times as necessary.
A block can be defined in the current working area or saved as separate
.dwg file.
The blocks saved as .dwg files can be grouped on the Tool palette.
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Example 1: Creating a block on the drawing
All doors in the example project are of the same type. In this example,
create a door symbol with the shape and size given in the following
figure and save it as block. Activate the Doors layer.

1. Create a line and an arc or a polyline.
2. On the Blocks & References tab, on the Block panel, click
.
3. In the “Block definition” dialog box, make the following settings:
– In the “Name” field, enter Door
for the name of the block.
,
– In the “Objects” area, click
select the elements previously
drawn and press Enter.
– In the “Base point” area, click
to define the reference point

of the block.
– Select the Delete from drawing option.
The block is created and the block entities are removed from the display.
The block is available only in the current drawing.
Blocks created in separate .dwg files can be reused in other drawings.
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Example 2: Saving a block in a separate .dwg file
In this example, save the previously created block in a separate .dwg file.
1. On the Blocks & References tab, on the Block panel, click
.
2. In the “Write block” dialog box, make the following settings:
– Select Block as source of the
.dwg file.
– In the “File name and path:” field,
enter Door as the name of the
.dwg file.

The block is saved on the disk in a .dwg file.
Example 3: Inserting a block
1. On the Blocks & References tab, on the Block panel, click

.

2. In the “Insert block” dialog box, make the following settings:
– Select the Door block.
– Select the Specify Onscreen option for the
Insertion point and Rotation
angle.
– Enter the X and Y scale
factor.
3. Click Insert.
The block appears attached to the cursor.

4. Click the insertion point of the block.
5. On the command line, enter 0 for the rotation angle.
The door symbol is inserted.
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Using a similar process, insert all the necessary door symbols with the
corresponding rotation angle.

DIMENSIONS
Advance CAD provides tools for creating all dimension types.
•

Aligned linear dimensions

•

Angular dimensions

•

Arc length dimensions

•

Linear dimensions from a base point

•

Diameter dimensions

•

Ordinate point dimensions – displays the X and Y coordinates of the
selected point

The Dimensions panel of the Home tab contains all the necessary tools
for creating dimensions.
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Linear dimensions
The linear dimensions tool adds horizontal and vertical dimensions to
entities.
Example 1: Creating a linear dimension by two points
Dimension the window opening in the inner wall.
For a clear view, hide the Furniture layer. The dimensions are created
on the Dimensions layer.
1. On the Home tab, on the Dimensions
panel, select

from the flyout.

2. Select the first point to dimension (the
origin of the first extension line).
3. Select the second point to dimension
(the origin of the second extension line).
4. Click a point to place the dimension line.

Tips:

To dimension a single line, instead of selecting the origin of the
first extension line, press Enter. Select the line to dimension.
All you have to do is placing the dimension line.

Using the same process, create linear dimensions.
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Example 2: Creating a continue linear dimension
Dimension the upper horizontal wall. First, create a linear dimension for
the first segment of the wall.
The continue dimension works only on existing dimension and creates
the same type of dimension as the existing one.

Before starting, activate the Dimensions layer.
1. On the Home tab, on the Dimensions panel, select
the flyout.
2. Press Enter to select the dimension with which to start.
3. Select the dimension with which to start.
4. Select the next extension line origin.
5. To add continued dimensions, keep selecting extension line origins.
6. Press Enter twice to end the command.

Using the same process, create all necessary dimensions.
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Angular dimension
Angular dimensions are used for annotating the angle between two lines or
an arc. Angular dimensions can be created by defining the angle vertex
and two endpoints or an angular dimension can be used as a start for a
continue dimension.
Example 1: Creating an angular dimension
In this example, dimension the window opening on the circular wall.
1. On the Home tab, on the Dimensions
panel, click

.

2. Press Enter to create an angular
dimension.
3. Select the angle vertex.
4. Select one side of the angle.
5. Select the other side of the angle.
6. Click a point to define the dimension line
position.
Next, use the angular dimension as a start for the continue dimension.
1. On the Home tab, on the Dimensions
panel, select
from the flyout.
2. Press Enter to select the dimension with
which to start.
3. Select the dimension with which to start.
4. Select the next extension line origins.
5. Press Enter twice to end the command.
Example 2: Creating an arc dimension
1. On

the

Home

tab,

on

the

Dimensions panel, select
from the flyout.
2. Select the outer contour line of the
circular wall.
3. Click a point to define the dimension
line position.
The arc dimension is created.
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Radial dimension
Radial dimensions are used to annotate the radius of arcs and circles.
Example: Creating a radial dimension
1. On the Home tab, Dimensions panel,
select

from the flyout.

2. Select the inner contour line of the
circular wall.
3. Click a point to define the dimension
line position.
The radial dimension is created.

Diameter dimension
Diameter dimensions are used to annotate the diameter of arcs and circles.
Example: Creating a diameter dimension
1. On the Home tab, on the Dimensions
panel, click

.

2. Select the circle (the contour of the
circular column).
3. Click a point to define the dimension
line position.
The diameter dimension is created.

This small exercise was a very simple introduction to Advance CAD.
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