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1. Introduction 
 

1.1 Welcome to Advance Design 

From modeling to structure calculation, result post-processing, and structure optimization, Advance 
Design offers a complete environment for the static and dynamic analysis of 2D and 3D structures 
using the finite element method. 

This software also provides advanced design capabilities for steel, reinforced concrete, and timber 
structures. The verification of steel elements starts from an initial dimensioning and may continue with 
several successive optimizations. The reinforced concrete design determines, by several available 
methods, the theoretical reinforcement area, and the reinforcement ratios of concrete elements. 

 

Advance Design is a new generation of analysis software, improved with powerful 

and innovative features: 

1.  Complete integration of finite elements / reinforced concrete/steelwork/timber analysis 
modules 

2. Possibility to perform various tasks, such as: 

• Model your structure with the assistance of various CAD tools (workplane, coordinate 
systems, snap modes, etc.) and CAD functions (extrude, subdivide, trim, extend, create 
symmetries, etc.). 

• Input structure assumptions (materials, cross-sections, loads, analysis types). 
• Create a mesh using two powerful mesh engines (Advanced and Standard Mesh). 
• Calculate the structure using a new generation solver engine. 
• View the results choosing from a large set of visualization options. 
• Calculate and optimize reinforced concrete, steel, and timber structures according to 

standard regulations. 
• Generate calculation reports using a variety of predefined result tables. 

 
 

1.2 About this Guide 

This guide describes the main functions and interface of Advance Design, and, through a few small 
examples, the program's working process. The examples follow each description of Advance Design 
functions. 

This guide is a brief introduction to Advance Design and not all its features are described. For detailed 
information regarding the program functions, refer to the Advance Design Help.  

 

 

https://graitec.com/advance-design/
https://graitec.com/advance-design/
https://www.graitec.com/Help/Advance-Design/desktop/Advance-Design-Help.htm
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1.3 Technical Support 
 
GRAITEC technical support is available by phone, fax, or email. To reach GRAITEC technical support: 

• Ribbon: Manage tab: click Technical support to send an email to GRAITEC. 
• Menu: select Help > Technical support. A template email is sent to the technical support team 
who will quickly solve the problem and provide a precise answer. The model of the current project 
is automatically archived and attached to the message. 
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2. What is Advance Design  

Advance Design, structural analysis software designed for the civil engineering field, offers a complete 
and fully integrated environment from the structure modeling to the result post-processing and 
structure optimization. 

It provides a complete range of functions specialized in advanced CAD modeling, meshing, calculation, 
verification, and optimization of reinforced concrete, steel, and timber structures, result post-
processing, and generating high-quality reports. 
 

The study of a project in Advance Design environment is designed in four operating modes: Model, 
Analysis, Design, and Document. 

 
Four operating modes: Model, Analysis, Design, and Document 
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3. Installing Advance Design 

3.1 System Requirements 
 
To successfully install Advance certain requirements must be met. 
For complete details, access the Installation guide or Graitec Advantage. 
 

3.2 Advance Design Installation 
 
Before installing Advance Design: 
 

• Make sure you have administrator rights under Windows. 
• Close all open applications. 

 

Proceed with the installation as follows: 
 
1. Access Graitec Advantage on your browser and log in with your credentials. Find product releases 
sorted by type and year, under the Downloads section. You can either download a DVD ISO image of 
the software or download and run the online installer. If the AutoPlay tool on the computer is switched 
off and thus the setup does not start automatically, use the Run command: 

• From the Windows menu, select: Start > Run. 
• In the Run dialog box, click Browse to select the SetupAdvance.exe program. Click <OK>. 

 
2. Select the installation language and click Install products. 
 
3. On the next screen, select Advance Design and click Next. 
 
4. Read the license agreement. Select I accept to agree to the specified terms and click Next to 
continue. 
 
5. On the next screen, select the interface language and the installation path. 

• To select the interface language, click Customize. In the next dialog box, select the 
interface language and the local settings for each installed application and click <OK>. 

• To change the destination path, click . In the next dialog box, enter a path or select a 
different folder in which to install Advance and click <OK>. 

6. Click Install to start the installation. 
 
7. Wait a few moments while Advance Design is installed on the computer. Click Exit when the 
installation is complete. 
 
After installing Advance Design, a license is required to use the software. The license is activated 
based on the activation code and the serial number provided by the dealer. Once the license is 
successfully activated, the software can be used according to the license rights. 

Without the authorization code, a temporary license for 15 days may be installed. The activation 
process starts with launching Advance Design. Follow the procedure described in the Installation 
guide. 

https://graitec.info/Advance2023/Documentation/Advance-Installation-Guide-2023_EN.pdf
https://advantage.graitec.com/en-US/downloads/Documentation/
https://advantage.graitec.com/en-US/
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4. Starting Advance Design  

Advance Design can be launched using various methods: 

1. From the Windows Start menu, select Programs > Graitec > Advance Design. 

2. Double click the Advance Design icon on the desktop. 

3. To start another work session simultaneously: 

• Double click an existing .fto file in its disk location. 
• Double click the Advance Design icon on the desktop. 

 

4.1 Project Management 
 

Each time Advance Design is launched, the Start-up Page helps you to create and configure new 
projects while managing and providing fast access to the existing ones. 

The Advance Design start page has a left-side panel and two slides: CREATE and LEARN.  

 

Example: Configuring a new project 

1. On the left side panel of the CREATE page, click Configuration. 

2. In the Localization settings dialog box make the following settings: 

• Select the language to be used for the interface and the calculation reports. 
• Select the Combinations standard: EC0 – General. 
• Select the Seismic standard: EC8 – General. 
• Select the Climatic standard: EC1 – General. 
• Select the Reinforced Concrete standard: EC2 - General. 
• Select the Steelwork standard: EC3 – General. 
• Select the Timber standard: EC5 – General. 
• Select the Masonry standard: EC6 – General. 
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Configuring a new project 

 

3. Click OK and then select New from the left side panel to open a new project. 

4. Enter details about the current project: name, lot, address, etc. These details are displayed in the 
reports generated for the current project. 

 

Project settings 
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Also, you can open the List of stakeholders dialog box where you can enter details about stakeholders 
and browse for an image file to add it as a project logo. When the Show in cover sheet option is 
enabled, the information provided in this dialog box is displayed on the report cover sheet. 

5. Click Next to define the general structure configuration. 

 

Project Settings: Workspace, Characteristics, Units  
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5. Advance Design Environment 

Advance Design offers a complete environment for modeling, analysis, design, and result post-
processing - all fully integrated into the same interface. 

Advance Design- General presentation  

 

No. Interface component Main function / use 

1 Quick Access Toolbar 
Element integrated into the title bar and designed to provide one-
click access to basic commands, such as "Save", "Redo" or "Print". 
You can customize it by adding the most used commands/features 
from the ribbon tabs. 

2 Main Menu button 
Clicking this top-left corner button displays a list of the Advance 
Design commands. The menus are listed from top to bottom 
considering the order of the work process steps. Position your 
cursor over a specific menu to further access specific commands. 

3 Ribbon 
A more user-friendly alternative to the previous standard menu 
bar, this interface component improves Advance Design usability 
by grouping commands into logical tabs and categories. Each tab 
in the new Advance Design ribbon allows access to several panels 
of commands. You can display or hide the tabs and their panels in 
the ribbon, by double-clicking on each tab. 

4 Toolbars 
Different types of commands are grouped in toolbars, which can 
be easily displayed and positioned (i.e., floating or docked) by 
drag-and-drop in the application environment. The toolbars that 
are active only in certain steps of the project (such as Modeling, 
Analysis Settings, Analysis - F.E. Results, etc.) are automatically 
displayed or hidden, to optimize the workspace during the work 
process. 

5 Project Browser 
The main control center of your Advance Design project, this tree-
structure navigator displays different content in each working step 
of the project allowing quick access to commands varying from 
object selection to structure meshing or results post-processing. 
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6 Properties window 
The attributes of all the model entities can be viewed and modified 
in the properties window. The properties are displayed in a tree 
structure in various categories. The properties window is 
displayed dynamically when an element (or a drawing tool) is 
selected and provides access to the common properties of a 
selection of elements of the same type. 

7 Status bar 
The status bar displays information regarding the program status 
during different phases of the project. It also contains buttons that 
provide access to the configuration of certain parameters: snap 
modes, objects tooltip content, current coordinate system, and 
working units. 

8 Graphic area 
The graphic area represents the design area of the application; it 
provides easy and intuitive use of CAD commands and a realistic 
rendering of the model. It also allows you to perform practical 
actions like element drawing or selection. 
The graphic area can also be split into several viewports (from one 
to four); each of these viewports can have different display 
settings and a different viewpoint (i.e., zooms on a certain part of 
the structure, realistic or simplified rendering, etc.). 
The default workplane of the drawing area assists in structural 
modeling. The workplane's parameters can be defined and the 
workplane is easily hidden or displayed during the work process. 

9 Command-line 
The command line informs about the status of an action, assists in 
the drawing process, informs about errors, etc. It contains three 
tabs: 

- Information: displays the status of the current operations. 
- Errors: displays warnings and error messages. 
- Edit: this allows the dialog between user and application; 

provides the option to draw/modify objects by typing 
parameters in the dialog area of the command line. 

10 Coordinate system 
The global coordinate system is represented by a three axes 
symbol permanently displayed in the graphic area. It is also 
possible to create one or several user-defined coordinate systems 
(Cartesian or polar). 

 

The program interface is intuitive and enhanced for easier manipulation of its different components 
and commands (i.e., advanced docking, undocking, auto-hiding, tabbing, etc.). 
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6. Modeling: Creating the Descriptive Model 
 
The structure modeling may be done entirely with the use of various CAD tools via the graphic area, 
where a 2D or 3D representation of the model can be visualized at any time. 

The various zoom and view commands (e.g., rotate around the model, predefined views, etc.) provide 
fast and easy manipulation of the graphical elements. 
 

6.1 Advance Design Elements 
 
Advance Design provides a complete library of structure elements, supports, and geometric entities. 
 

 

Example Element type 

 

Linear elements (bar, beam, short beam, variable beam, tie, strut, cable) 

 

Planar elements (membrane, plate, shell, plane strain, steel deck) 

 

Supports (point, linear and planar supports, which can be rigid, elastic, 
traction only / compression only, or non-linear) 

 

Load areas: elements used for the distribution of loads on the supporting 
elements 

 

Points 

 

Lines and polylines 

 

Grids 

 

Dimension lines 
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➢ 6.1.1 Creating elements 

Elements are drawn in the graphic area using the keyboard (by typing coordinates on the command 
line) or the mouse, relative to the workplane's points or existing entities. Advance Design also provides 
various automatic drawing tools (e.g., generate elements on selection, portal frames, and vaults 
generators, etc.). 

 
Example: Creating structure elements 

1. On the Home tab, Linear & Planar panel, select Linear element. 

2. In the graphic area (XZ plane), click to define a column at 0 0 coordinates for the first extremity and 
0 7 for the second one. 

 

 

3. With the linear element drawing tool still active, type on the command line the coordinates for the 
second column: 12 0 for the first extremity and 12 7 for the second one. Input a space between 
coordinates and press Enter after each extremity definition. 

 

 

4. Draw the upper beam between the two columns, using the "Extremity" snap mode: 
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5. Draw a 3 meter high column placed at 6 0 XZ coordinates. 

 

 

6. Create a storey beam: with the linear element drawing tool still active, press <Alt + S> to access the 
snap modes dialog box; select the perpendicular snap and draw the beam as shown below. 

 

 

7. On the Home tab, Supports panel, select Rigid Point; in the drawing area, click the bottom extremity 
of each column, to create supports. 
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➢ 6.1.2 Definition of element properties 

The attributes of each element are defined in the properties window (e.g., name, ID, and different 
parameters). By default, the properties window appears when an element is selected and auto-hides 
when it is empty. 

 
Example: Defining the element properties 

1. Click the two columns and the beam of the main portal frame to select them. 

 

 

2. In the properties window make the following settings: 

• Material: C25/30. 
• Cross-section: R60*90. 

 

3. Select the storey column, and, in its properties window, select the S235 material. To define the 

element cross-section, click  to access the section library and select IPE200 from the "European 
Profiles". 

 

 

4. Proceed in the same way to define the material and cross-section for the storey beam: S235 - 
HEA200. 
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➢ 6.1.3 Systems of elements 

The structure elements that are created (also geometric elements, help entities, etc.) are stored in the 
Project Browser, in the Model mode. The Project Browser's context menus for each of its items provide 
rapid access to different modeling commands and advanced management of the elements (i.e., 
hide/display, select, delete, the group in systems, etc.). 

The system concept helps define the behavior of different groups of elements (e.g., assign design 
templates). Different operations are easily performed on a group of elements using their system's 
context menu commands. The level function available in the system's properties window defines the 
level settings and thus creates faster and easier structure elements on different altitudes (levels): a 
column using one click, a wall using two clicks. 

 
Example: Creating a system of elements 

1. In the Project Browser, right-click Structure and select Systems management / Create a subsystem 
from the context menu. 

2. Type the system name: Portal frame. 

3. Select the Portal frame system, and using the steps described above, create the following 
subsystems: Columns, Beams, Supports, and Load Areas. 

4. Create a Storey system under Structure with the Columns, Beams, Slabs, and Supports 
subsystems. 

 

Creating a system of elements  
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5. In the Project Browser, select the two columns of the portal frame and drag and drop them to the 
Portal frame > Columns system. 

 

Using the same method, place all the elements of the model in the corresponding systems. 

 

➢ 6.1.4 CAD functions 

The graphical input of the model is very easy and accurate, using advanced CAD commands. Easily 
copy (i.e., by rotation, translation, or symmetry), move, extrude, trim, or extend, subdivide, cut, create 
openings, etc. using a large set of commands accessible from various locations (i.e., menus, context 
menus, toolbars, etc.). 

 

CAD functions  
 
 
Example: Copying elements 

First, define a 3D view of the workplane: on the Home tab, Views panel, click  (or press <Alt + 6>). 

1. Press <Ctrl + A> to select all the elements of the model. 

2. Right-click the drawing area and select Copy (or press <Insert>). 
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3. In the ‘Multiple copy’ dialog box, define the copy parameters: 

• Copy by Translation. 
• Vector: 0 6 0. 
• Number: 3. 

 
 

Copy function 
 

4. Click Preview to display the result. 

5. Click Copy to apply. 

 

Create the rest of the storey elements: 

• In the Project Browser, select the Storey > Beams subsystem. 
• Select the linear elements drawing tool and draw two longitudinal beams (S235 with HEA200 

cross-section). 
• Select the first transverse beam and make 2 copies in the 0 2 0 direction. 
• Select the two copied beams and define, in their properties window, an S235 material and an 

IPE200 cross-section. 
• Make 2 copies of the selected beams in the 0 6 0 direction. 
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➢ 6.1.5 Generating loads 

Loads are generated and organized using the Project Browser. Loads are grouped in the Project 
Browser under "Loading" in load cases (i.e., self-weight, static, seismic, etc.) and case families 
(permanent loads, live loads, snow, wind, temperatures, etc.). Each case family may contain several 
load cases, and each load case may contain several loads. 

 

Loads are grouped in the Project Browser  
under "Loading" in load cases 

 

Loads are generated via the graphical input, using the load creation tools available on the Home tab - 
Load Case & Loads panel, in the Project Browser or menus. The automatic tools (i.e., pressure loads 
generator, climatic loads generator, loads on selection, etc.) can also be used. 

The parameters of loads, load cases, and case families are defined in their properties windows. The 
loads are managed using their context menu commands in the Project Browser. 

Once loads have been defined, load combinations and envelopes can be created (using the Project 
Browser or the Analyze menu commands). 

Using the combinations manager, combinations are manually created and the standard combinations 
available in Advance Design are loaded. 
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Generate a new Case Family 

 
 

Example: Generating loads 
 

• Generate the self-weight 

From the menu, select Generate > Load > Dead Loads. The ‘Dead loads’ family and a dead load case 
are automatically created in the Project Browser. 
 

• Create a live load 

First, create the storey slab. In the Project Browser: select the Storey > Slabs subsystem. On the Home 
tab, Linear & Planar panel, select Planar element and draw the slab as shown. 
 

 



Advance Design Starting Guide 
 

 22 

In the slab's properties window define: 

• Material: C25/30. 
• Thickness: 15 cm. 

• Design > Concrete Design > Cracking > Reinforcement definition >   and make the 
following settings: 

 
 

Reinforcement definition 
 

1. In the Project Browser: right-click Loading and select Create a case family from the context menu. 

2. In the displayed window, select Live Loads. 

3. Click <OK>. A live loads family and a corresponding case are created in the Project Browser. 

4. Select the 2L live load case in the Project Browser. 

5. In the drawing area, select the storey slab. 

6. Right-click and select Loads/selection from the context menu. 

7. The planar load's properties window is automatically displayed: input the loads' intensity on FZ: - 5 
kN/m. 

8. Click <OK>. 

 

 
• Generating snow loads 

First, create two beams and a load area on the portal frame: 
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1. In the Portal frame > Beams subsystem create two longitudinal portal frame beams, using a C25/30 
material and an R40*60 cross-section. 

 
 

2. In the Project Browser: select the Portal frame > Load Areas subsystem. Select the two longitudinal 
beams; right-click and select Load Areas / Selection from the context menu. On the Home tab, the 
Render modes panel, enable the ‘Axes’ rendering mode. This provides a view of the span direction on 
load areas. In the load area properties window: set the span direction towards the longitudinal beams, 
considering the load area's local axes. 

 

Loads Distribution 

 

3. In the Project Browser: right-click Loading and generate a snow family using the same steps 
described above. A snow family and a snow load case are created in the Project Browser. 

4. In the snow family properties window: 

• Enter 0.52 kN/m² in the ‘Snow load’ field. 
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5. To automatically generate the snow loads on the load area, select Generate > Load > Climatic 
loads from the menu. 

 

Loads presentation 

 
 
Example: Creating load combinations 

1. In the Project Browser, right-click Combinations and select Properties from the context menu. 
2. In the ‘Combinations’ dialog box, click Simplified Comb. 
3. Define the Live loads and Snow loads as predominant actions. 
4. Click Generate. 

 

 

Creating load combinations 
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6.2 Defining Analyses 
 
During the modeling step, Advance Design provides commands for defining several types of analyses 
(i.e., modal, buckling, static nonlinear) and for the concrete and steel design settings. 

Access the Settings menu to select the desired analysis. For each type of analysis, a default analysis 
case is also automatically created. 

 

Create a modal analysis 

 

Manage analyses using the Project Browser's commands. View and select the created analyses with 
the project browser. 

 

 

The analyses cases parameters are defined in the properties window. 
 
 
 

Example: Defining a modal analysis 

1. Menu: select Settings > Modal Analysis. 
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2. In the Project Browser, a modal analysis family and the ‘Modes’ case are placed in the ‘Settings’ 
group. Select the ‘Modes’ case to display its properties window. 

3. Define the modes' parameters: 

• The number of vibration modes: 10. 
• Masses definition: select masses obtained by combining static loads from the drop-down list 

and, in the ‘Combinations’ field below, click  to access the masses combinations dialog box. 
Define here the following combination: 1*1D + 0.6*2L. 
 
 

 
Defining a modal analysis 

 
 

• Mass percentage on Z: 0%. 
 
 

6.3 Model Verification 
 
At any time during the modeling step, the model's coherence and integrity can be verified with the 

verification function. Access the Analyze menu > Verify command or click  (Verify) on the Home 
tab. If there are errors or warnings, they are displayed on the command line. If there are no errors, a 
confirmation message will be displayed. 
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7. Analysis: Meshing and Calculation 

In the next step, after the verification of the model's coherence and validity, the program creates the 
analysis model. The structure meshing and the model calculation are performed using the defined 
analyses (i.e., finite elements calculation and concrete/ steel verification). 

 

7.1 Creating the Analysis Model 
 
To mesh and calculate the structure, it is necessary to create the analysis model. Once the model's 
validity is verified, access the Analyze > Create the analysis model command, or, in the Project 

Browser, click . 

A wizard provides options to combine the desired operations (i.e., verify, mesh, finite elements 
calculation, reinforced concrete calculation, etc.) into a calculation sequence that is automatically 
performed. 

 

Creating the Analysis Model 

 

The analysis model's components are controlled and viewed in the Analysis mode in the project 
browser. The available context menu commands for each element of the project browser manage the 
analysis operations. 
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Analysis functions 

After the analysis model creation, new panels and commands are available (e.g., the Analysis Model 
panel from the Analysis tab), while the modeling tools are inactive. 

 

 

Analysis Model- Mesh options 
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7.2 Meshing 
 
Two different mesh engines are available in Advance Design: ‘Grid’ and ‘Delaunay’. 

The finite element meshing is performed using the global mesh settings (defined via the Options > Mesh 
command) and the mesh parameters defined for each element (available in the properties window). 
The mesh parameters of each element are defined using the simplified method (i.e., a meshing density 
along each of the local axes) or the detailed method (i.e., a meshing density for each of the element's 
sides). 

 
Example: Defining the model meshing 
 

• Create the analysis model and the model meshing 

1. In the project browser, click  to access the ‘Calculation sequence’ dialog box. 

2. Select Mesh and click <OK>.     

Advance Design creates the analysis model and automatically performs the model meshing. 

 

Create the analysis model and the model meshing 

 



Advance Design Starting Guide 
 

 30 

• Modify the mesh density 

1. From the menu, select Options > Mesh. 

2. In the ‘Mesh options’ dialog box, modify the mesh density: in the ‘Element size by default’ field, input 
0.5 meters. 

3. Click <OK>. 

 
Mesh options 

 

 
• Recreate the mesh 

On the Analysis tab, Analysis Model panel, select Mesh. 

The meshing is modified according to the global settings. 
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7.3 Calculation 
 
After meshing, Advance Design is ready to calculate the model. The ‘Calculate’ command provides 
access to the ‘Calculation sequence’ dialog box, where the calculations to perform is selected. 
 

 

After meshing, Advance Design can calculate the model 

 

➢ 7.3.1. Finite elements calculation 

A powerful finite elements engine performs the model calculation according to the structure settings: 

 
• Defined analyses (static and dynamic calculation, linear and non-linear analyses, large 

displacements, generalized buckling, etc.). 
• Finite elements parameters of structure elements (defined in the properties window). 

 

Before the calculation, it is possible to select the elements to calculate and the type of results to 
obtain, for optimizing the calculation speed and the memory usage. 
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Application- general settings 

 

During the analysis step, it is possible to specify the analyses to calculate (using the Project Browser 
commands). 

 

 

Advance Design can group analyses in calculation phases and calculate them step by step (allowing 
property modifications for each phase). 
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Analysis- Calculation by Phases 

 

➢ 7.3.2 Reinforced concrete calculation 

The reinforced concrete engine calculates the reinforcement of concrete elements by serviceability 
limit states (SLS) and ultimate limit states (ULS and AULS) and verifies the concrete cross-sections 
using interaction curves. 

The reinforced concrete calculation is performed only if the regulatory load combinations are created, 
and the calculation of the finite element was run. The reinforced concrete calculation considers the 
global and local concrete design settings: 

 

Global concrete settings Local concrete settings 
Pertains to the calculation methods of reinforced concrete, 
the columns verification, reinforcement and buckling 
parameters, etc. 

The local concrete design settings 
are defined in the properties 
window of the appropriate 
elements. 
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➢ 7.3.3 Steel calculation 

Advance Design provides a steel calculation engine, which performs the calculation of steel elements 
according to standard regulations. The steel expert verifies deflections, the cross-section’s 
resistance, and the element's stability according to second-order effects (buckling and lateral-
torsional buckling) and optimizes the steel shapes. 

The steel calculation is performed only if the standard load combinations are created, and the 
calculation of the finite element was run. 

The steel calculation considers the global and local steel design settings: 

Global steel settings Local steel settings 
Pertains to the steel calculation methods, the optimization 
criteria, the buckling calculation methods, etc. 

The local steel design settings are 
defined in the properties window of 
the appropriate elements. 

 

 

 

Note: After the calculation, the results can be viewed and the element parameters modified, if 
necessary. The desired calculations can be iterated until the appropriate results are obtained.  

 
Example: Running a complete calculation sequence 

1. From the Analyze menu, select Calculate. 

2. In the ‘Calculation sequence’ dialog box, select: 

• Finite elements calculation, 
• Reinforced Concrete calculation, 
• Steel calculation. 

3. Click <OK> to launch the selected operations. 
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Calculation Sequence 

 

The command line displays the performed operations and a message when the calculations are done. 

 

Command Line presentation 

 
  



Advance Design Starting Guide 
 

 36 

8. Results Post-processing 

The phase following the model calculation, also called the post-processing step, displays the results 
on the graphical model or as calculation reports, results from curves on the selected elements, etc. 

 

8.1 Graphical Visualization of Results 
 
A new set of tools and commands are active during the results post-processing step. They provide 
different modes to display the desired results. Several results visualization commands are available: 

• On the panels in the Results tab, which appear automatically once the corresponding 
calculation is done. 

 

Results tab: FEM, RC Design, Steel Design Results 

 

• From the element's context menu: it is possible to display in the graphic area the results of the 
selection. When a selection is not defined, the results are displayed on the entire structure. 

 

 

• Using the results configuration dialog box, that provides a detailed configuration of the results 
display. Different visualization modes are available: colors, values, deformed shape, iso-
values, iso-regions, vectors, etc. 
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Results Settings dialog 
 
 
Example: Creating graphical post-processing of FE results 
 

• View the displacement results on the storey slab 

1. First, right-click in the graphic area and disable Display nodes from the context menu. Define a top 
view of the workplane: press <Alt + 3>. On the FEM Results panel, select the Displacements result 
type, the D planar elements results, and the combination no. 101. Click Post Processing to perform the 
post-processing. 

2. Define a (-1, -1, 1) view of the workplane: on the Home tab, Views panel, click . In the Result 
Settings dialog box - Options tab: select Display results on the deformed and Automatic scale of 
the deformed. 

 

Post Processing result- Displacement on planar elements 
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3. Right-click the graphic area and deselect Display the mesh from the context menu. 

4. Open the results configuration dialog box (press <Alt + Z>), access the Options tab, and select 
Extreme values. 

 

 
• View forces results on the concrete linear elements 

1. Select the concrete elements using the selection by criteria: press <Alt + S>; in the ‘Elements 
selection’ dialog box, access the Materials tab and select C25/30. Click <OK> to apply. 

2. On the FEM Results panel, select the Forces result type, the Fy linear elements results, and the 
combination no. 101. Click Post Processing to perform the post-processing. 

 
 

View forces results on the concrete linear elements 
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• View stresses on steel elements 

First, right-click the drawing area and select Cancel selection from the context menu. 

1. Define a new selection by criteria: press <Alt + S>; in the ‘Elements selection’ dialog box, access the 
Materials tab, and select S235. Click <OK> to apply. 

2. On the FEM Results panel, select the Stresses result type, the Sxx linear elements results, and the 
combination no. 101. Click Post Processing to perform the post-processing. 

 

 

View stresses on steel elements 

 

To clear the results displayed on the screen: hold down the <Esc> key for a few seconds. 

 

➢ 8.1.1 Result curves 

Different results (i.e., FE results as displacements, forces, stresses, and concrete reinforcement area) 
can be viewed using the "Result curves" command available in the post-processing step of the project. 

Result curves can be obtained on linear and planar elements using section cuts. The result curves 
diagram is configured using various options available from the diagram's dialog box. The diagram can 
be saved as an image or it can be printed using specific commands. 
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Example: Displaying result curves on a section cut 

First, create a section cut: 

• Right-click the drawing area and select Generate an entity > Create a Section Cut from the 
context menu. Draw the section cut on the length of the storey slab as shown in the figure. 

 

Positioning Section Cut 

 

Then, select the analyses displayed on the curve and view the results: 

• Press <Alt + Q> to access the ‘Analyses and combinations’ dialog box. 
• On the Forces, tab click None to unselect all loads combinations, and then select only the 101 

loads combination. 
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Analyses and Combinations 
 

 
• Select the section cut. 

• Click   in the Results tab, Post-Processing panel. The default result curves (Mxx and Myy) 
for the selected analyses are automatically displayed. 
 

 

Results Curves on Section Cut 1 
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➢ 8.1.2 Stresses diagrams 

The analysis of the stresses distribution on a given section is performed using the section stresses 
command. A stresses diagram is obtained. The diagram dynamically displays the stresses results on 
each point of the linear element. 

 
Example: Displaying a stresses diagram 

Select the storey beam on which to display the section stresses results: 

• Position the mouse cursor above the desired beam; the tooltip displays the details of 
the element focused by the cursor. 

• Press the <Tab> key to snap to different elements placed on the cursor trajectory; 
when the cursor focuses on the beam of interest (i.e., S235 material, HEA200 cross-
section) - click to select it. 

 

From the menu, select Analyze > Cross Section Stresses. 

The sections stresses diagram is displayed in a new window. Use the slider to view the stresses on each 
point of the beam's length. 

 

Linear elements stresses 
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➢ 8.1.3 Post-processing animation 

An animation can be created in Advance Design, starting from the graphical results post-processing, 
following the results distribution and the deformed shape of the structure. 

The Animation panel in the Utilities tab provides access to all necessary commands for creating and 
recording animations. 

 

Animation functions 

 
 

Example: Creating a post-processing animation 

1. On the FEM Results panel, define the following results post-processing: 

• Select the Eigenmodes result type. 
• Select Eigen mode 3 from the analyses drop-down list. 
• Click Post-processing. 

2. Define a front view of the workplane: on the Home tab, Views panel, click . 

 

Displaying results for modal analysis 
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3. On the Results tab, Post Processing panel, open the ColorMap Configuration drop-down list and 
select Animation to view the post-processing results in animation. 

To stop the animation: press the <Esc> key. 

 

8.2 Design Post-processing 
 
In the post-processing phase, once the corresponding calculations are performed, the results of the 
concrete/steel verifications can be viewed. Moreover, the steel members of the structure can be 
optimized using the functions provided by these design modules. 

For this purpose, a set of specialized panels and commands are available, fully integrated within the 
same interface. 

 

 

➢ 8.2.1 Reinforced concrete results 

The reinforcement results on concrete elements (i.e., reinforcement area, buckling lengths, 
reinforcement ratios) are viewed using the Results tab, RC Design Results panel, which is available 
when the concrete calculation is completed. 

 

In the properties window of certain concrete elements (columns), the interaction curves issued from 
the reinforcement parameters, which are either determined automatically by the concrete module or 
set by the user, can be viewed. Therefore, it is possible to adjust, for example, a highly slender column 
exposed to oblique bending. 

 
 
Example: Viewing the longitudinal reinforcement on beams 

1. Define a (-1, -1, 1) view of the workplane by pressing <Alt + 6>. 

2. In the Project Browser, select Portal frame > Beams system and press <Space>. 

3. On the Results tab, RC Design Results panel: 

• Select the result type: Reinforcement. 
• Select the result on linear elements: Az. 
• Click Post-processing to perform the post-processing. 

The longitudinal reinforcement is automatically displayed as diagrams. The result values appear in the 
color legend displayed in the graphic area. 
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Viewing the longitudinal reinforcement on beams 
 

 
Example: Viewing the reinforcement results on a column 

1. Select one column of the portal frame. 

2. In the element properties window, go to the Design category > Reinforcement field. 

 

Properties- Reinforcement options 

 

3. Click   to open the ‘Modification of longitudinal reinforcement’ dialog box. The values of 
the real reinforcement and the calculated reinforcement for the selected column can be 
viewed. 
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Detailed rebar definition on a column 

 

5. Click Interaction curves to access the interaction curves window. 

 

Interaction curves for column 
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It is possible to view the position of the force component relative to the interaction area. For advanced 
visualization options, double-click the diagram, and the interaction curve is displayed in a new 
window. 

 

➢ 8.2.2 Steel results 

During the post-processing step, after the steel calculation, the steel expert module performs the 
verification of deflections, section resistance, and element stability according to second-order 
effects (buckling and lateral-torsional buckling), and the optimization of steel shapes. 

The steel results post-processing commands are available on the Results tab, Steel Design Results 
panel once the steel calculation is done. 

 

The calculated buckling and lateral-torsional buckling parameters for each steel element can be 
viewed in the properties window. 

 
Example: Verifying the steel elements' stability 

1. On the Steel Design Results panel: 

• Select the result type: Stability. 
• Select the result: Work ratio. 
• Click Post-processing. 
 

 
 

Example: Verifying the steel elements' stability 

 



Advance Design Starting Guide 
 

 48 

2. Access the ‘Results’ dialog box by pressing <Alt + Z>. 

3. Access the Options tab and select Extreme values. 

4. Click <OK>. 

 

➢ 8.2.3 Steel elements optimization 

The steel design module verifies the steel elements according to parameters specified by the global 
steel settings. 

The program identifies the steel shapes with a higher / lower work ratio than specified and suggests 
more appropriate cross-sections. 

 

 
 

Steel- General settings 

 

The suggested shapes can be accepted in whole or in part. Then, it is necessary to rerun the FE 
calculation and the structure optimization. These operations can be iterated until the appropriate 
work ratio is obtained for all steel shapes. 

 
Example: Optimization of steel shapes 

1. On the Results tab, Steel Design Results panel, click . The ‘Suggested shapes’ dialog box 
appears. The steel sections with a work ratio out of the specified range are displayed in red. 
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Optimization of steel shapes 

 

2. Click Accept all to accept the suggested shapes. 

3. Click <OK> to close and apply. 

4. Rerun the finite element calculation and the steel calculation. 

After the calculation, open the ‘Suggested shapes’ dialog box. If there are other suggested shapes, 
repeat the above steps until you obtain the work ratio comprised in the specified range for all steel 
shapes. 

 

 

➢ 8.2.4 Saved post-processing views 

A post-processing view saves the entire post-processing scenario (i.e., result type, result component, 
selected analyses and elements, results in visualization settings) together with the display settings of 
the model (i.e., viewpoint, rendering, etc.). For each post-processing view, a corresponding image file 
is saved to disk. The saved images are in the Document mode of the project browser. 

Post-processing views automatically replay the saved post-processing, without having to manually 
recreate the post-processing scenario. Moreover, if the structure settings were changed and the 
results were modified, the updated post-processing views display the new results. 

 
 
Example: Creating a post-processing view 

1. Define a (1, -1, 1) view of the workplane: press <Alt + 5>. 
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2. Set a ghost display of the descriptive model: on the Home tab, Render Modes panel, click  . 

3. Access the ‘Results’ dialog box by pressing <Alt + Z>. On the FE tab, select: 

• Forces result type. 
• My result on linear elements. 
• Mxx result on planar elements. 
• 101 loads combination. 

4. Click <OK>. 

5. On the Results tab, click Save View to save the post-processing. 

 

Creating a post-processing view-My efforts 

 

To access a saved post-processing view: double-click it in the Project Browser. 

 

➢ 8.2.5 Reports 

Advance Design provides an advanced and powerful report generator tool, with which the desired 
reports are easily defined. The available report templates can be used, or new templates can be 
defined. The report generator filters its content according to the current settings and available results. 
At the same time, the report content takes the selection of elements (if any) into account. 
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Example: Generating a report 

1. From the menu, select Documents > Standard Report; the report generator automatically loads the 
standard report template. 

 

Generating a report 

 

2. On the Post-processing tab of the report generator, select the post-processing view. 

3. In the report's content section, select the table with forces on planar elements and click the arrows 
to insert the post-processing right below. 

 

 

4. Click Case / Combinations and select only combination 101 in the Displacements, Forces, and 
Stresses tabs. 

5. Click Generate to start the report creation. When finished, the report is automatically displayed 
with the document viewer application. 
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9. Design Modules 
 
The Design mode is used for designing reinforced concrete elements and steel connections using the 
Advance Design Reinforced Concrete and Steel Connection modules. The Design mode is only 
available after the FEM analysis is completed. 

The Design Modules ribbon only becomes active after analysis is performed, and an element is selected 
in the Design tab of the Project Browser by double-clicking on it. 

The Design Modules tab of the Advance Design Ribbon provides you with access to commands from 
the Reinforced Concrete module and Steel Connection module. This way, you can achieve the entire 
design process within Advance Design. 

 

The Design Modules tab of the Advance Design Ribbon 
 
 

9.1 Concrete Elements 
 
Once the FEM analysis is complete, the user can open any element from the model by: 
 
1. Applying the Open with Design Modules command from the contextual menu 
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2. By double-clicking on an element in the Design tab of the Project Browser. 

 

 
 

Five types of concrete elements can be calculated using the Advance Design modules: footings 
(continuous and isolated), beams, columns, slabs, and walls. 
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Advance Design modules: isolated footing 

 

 

Advance Design modules: beam 
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Advance Design modules: column 

 

 

Advance Design modules: slab 
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Advance Design modules: wall 

 

 

The unavoidable step before running a structural design session is to define the structural design 
assumptions.  

Structural design assumptions can be split into two different families: 

• Design assumptions (Design Settings) 
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Design Assumptions 
 
 
 

• Constructive dispositions for the automatic placement of bars inside concrete members 
(Reinforcement Settings) 

 

Reinforcement Assumptions 
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Both assumption families (Design and Reinforcement) are country-code dependent (Eurocodes with 
different national appendixes, US codes, Canadian codes, NTC codes).  

When all assumptions are set, you can calculate the model. The modules will automatically generate 
the reinforcement needed for the efforts transferred from Advance Design. 

 

Presentation of Main and Secondary bars 

 

After the reinforcement is generated, you still have the option to adjust it. The reinforcement can easily 
be modified, or new bars can be added, with the possibility to see if the area of modified bars exceeds 
the theoretical area calculated by the Advance Design module. 

The calculated reinforcement can be restored at any point by using the ‘Restore from calculation’ 
option. 

 

Reinforcement dialog - ‘Restore from calculation’ option  
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The status of calculation results is displayed in the Design mode for each separate element after 
performing the calculation. A green check sign will appear for the calculated element that has no error 
message or failed verifications, which means that the obtained maximum work ratio for that element 
is smaller than 100%. Otherwise, when at least one verification provides a work ratio greater than 100% 
or at least one error message is displayed, an X red sign will appear. 

 

 

9.2 Steel Connections 

The steel connections available in Advance Design make it possible to quickly design a variety of 
connections in Advance Design projects. The Steel Connection module will help you work more 
productively when modeling, covering all the steps needed to define a steel joint and customize its 
properties including the main members of the connection, additional joint elements, connectors, and 
materials. 

Once the element is opened in the module (in the same way as for concrete elements), the joint 
elements and calculation assumptions can be modified to satisfy your needs. 

 

Steel Connection- Geometry dialog 
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The efforts from Advance Design are transferred as the envelope of efforts for a simple reason: for 
steel structure, there are too many load cases\combinations and the calculations take too long.  

Using the envelope, the calculation is done in just a few seconds. 

 

Steel Connection – Loads and combinations 

 

You can know exactly from which combinations from Advance Design the envelopes are created 
because in front of each envelope the combination is displayed. At any time, supplementary efforts 
can be added. 

The status of calculation results is displayed in the Design mode for each separate connection after 
performing the calculation. A green check sign will appear for the calculated connection that has no 
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error message or failed verifications, which means that the obtained maximum work ratio for that 
element is smaller than 100%. Otherwise, when at least one verification provides a work ratio greater 
than 100% or at least one error message is displayed, an X red sign will appear. 

 

 

9.3 Output: Calculation Results Tab 
 
For each performed verification, the ‘Calculation results’ tab displays the verification type, 
combination, value, limit, and work ratio. 
 

 

Calculation results 

 

Once the element is calculated, you can display the drawing on the screen, print it, or save the drawing 
on the computer. 
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On the drawing, the program automatically creates a bar schedule and a title block with all the 
information about the project and the element (this information will be imposed in ‘Drawing Settings’ 
from Advance Design modules). 

 

Interactive Drawings - Rigid Point Support  

 

You can manage all drawing components in the same window. For example, you can quickly add any 
number of new views to a given drawing. 

 

9.4 Advance Design Modules Reports 
 
One of the greatest features of Advance Design modules is producing a set of available reports.  
You can preview reports using the Report Designer tool or export them in DOC or PDF format. 
 
 

 
 

Report Designer tool 
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You can define general options regarding calculation reports such as report type, chapter 
customization, or saving options (format, location). These settings will be further considered when 
launching the reports generation or preview commands. 

 

Report presentation 

 

9.5 Masonry Wall Module 

Using the Advance Design Masonry Wall module, it is possible to design masonry walls, modeled as 
planar elements (shell elements). 

 

➢ 9.5.1 Workflow 

A masonry wall modeled in Advance Design must meet several conditions to be exported/opened in 
the Masonry Wall module: 

• Vertical planar element, 
• Material: masonry, 
• Shape: rectangular, 
• With/without openings. 

Please note that the masonry material contains information about the masonry construction (including 
the number and type of layers, their thickness, type of masonry units, and mortar) and can be created 
directly or imported from the Libraries. Depending on the norm selected in the Localization settings, 
different types of materials can be selected. Six types of walls (by the number and type of layers) are 
available and can be selected depending on your needs. 
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Material libraries 

 
 

Please note that the material properties (masonry unit, mortar, thickness, etc.) will be defined in the 
same window, depending on the selected standard: 
 

 
 

Properties 
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The workflow is the same as for reinforced Concrete walls: after running the FEM analysis, masonry 
walls can either be opened directly, using the Design tab or can be exported to the standalone module, 
using a command from the right-click menu. 

 

 

Opening/exporting a masonry wall in the Design Module 

 

The following data will be exported to the Masonry Wall module: 

• Wall Geometry 
• Openings 
• Loads: 

o Load cases and combinations 
o FEM results (efforts) 

In the Masonry module, you can modify the wall geometry, wall section, and design assumptions before 
running the calculation. 
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Masonry wall module 

 

 

➢ 9.5.2 Calculations and results 

The Advance Design Masonry Wall module supports calculations according to Eurocode 6 - with 
national appendixes, the Italian norm NTC 2018, and the Romanian norm CR6-2013. 

Note: The National appendix for Germany is not available in version 2023. 

Depending on the selected norm, the Masonry Module performs a Detailed or Simplified Calculation, 
and a Calculation report will be available. 
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Calculation report 

 

Please click on the links below for detailed information about the Advance Design Modules' capabilities 
and features: 

• Advance Design Steel Connection module 
• Advance Design RC Footing module 
• Advance Design RC Beam module 
• Advance Design RC Wall module 
• Advance Design Column module 
• Advance Design Masonry Wall  

https://www.graitec.com/Help/Advance-Design-modules/Steel-Connection/desktop/Explore_the_User_Interface.htm
https://www.graitec.com/Help/Advance-Design-modules/Footing/desktop/Explore_the_User_Interface.htm
https://www.graitec.com/Help/Advance-Design-modules/Beam/desktop/Explore_the_User_Interface.htm
https://www.graitec.com/Help/Advance-Design-modules/Wall/desktop/Explore_the_User_Interface.htm
https://www.graitec.com/Help/Advance-Design-modules/Column/desktop/Explore_the_User_Interface.htm
https://www.graitec.com/Help/Advance-Design/desktop/Masonry_Wall.htm

